Strange behaviour of revert action

After a lot of modifications in studio, I realized that the versioning was no more possible for a type of document in my 5.6 Nuxeo.

When I try something I always save the .jar in a special folder. Just in case.

I decided to try old .jar to understand my mistake and find when I did it.

So I have found the last “working .jar” and the first “not working .jar”.

4 operations appear between these 2 .jars in the “Project Versioning - Changes History”.

As I was not able to identify which one was responsible for the problem I decided to revert to the last operation before the last “working .jar”.

But If I generate a new .jar now, it is a “not working”.

I don't understand : should not this new .jar be exactly the same as the last working .jar ? As I was not able to identifie wich one was responsble for the problem I decided to revert to the last operattion before the last “working .jar”.

But If I generate a new .jar now, it is a “not working”.

I don't understand : should not this new .jar be exactly the same as the last working .jar ?

0 votes

1 answers

547 views

ANSWER

Strange : without doing anything in the studio, I generate a new .jar. This one works… There must be another parameter involved.
02/19/2014



Hi,

It looks like you ran into NXS-2000, this bug affected Studio from (roughly) Monday to Wednesday, very sorry for the inconvenience. The newly generated jar does not hold the bug, hence the change of behaviour (that was not linked to your own changes).

Note that when a version is tagged, the generated jar is kept as is and not generated again to ensure that the resulting behaviour does not change.

Thanks for reporting the problem

0 votes



OK, thank you.

I just lost time.

I prefer to know that the origin of the problem is not me.

02/24/2014