email notification not working

I'm trying to set up email notification for that i've read this article and since i'm using Gmail as server i've followed this configuration but it's not working. Is there extra configuration to add ? i'd mention that i've used same configuration with a PHP apllication and it's working , so maybe i'm missing something other than Gmail configuration . Any help would be appreciated. Here is my configuration :

Préfixe des sujets dans les notifications par email [Nuxeo]
Utilisateur pour l'authentification email   user@gmail.com
Mot de passe pour l'authentification email  password
Protocole de stockage des emails    pop3
Protocole d'envoi des emails    smtp
Nom d'hôte pour stockage des emails pop.gmail.com
Numéro de port pour stockage des emails 995
Nom d'utilisateur pour stockage des emails  user@gmail.com
Mot de passe pour stockage des emails   password
Mode de débugage    
Nom d'hôte pour la connexion transport  smtp.gmail.com
Numéro de port pour la connexion transport  587
Utiliser l'authentification pour la connexion transport 
Adresse email d'expéditeur  user@gmail.com
Utilisation de TLS pour la connexion transport  true
Destinataire des emails (ignoré dans Nuxeo) nobody

Edit here is the output of ./bin/nuxeoctl showconf

audit.elasticsearch.enabled=true
elasticsearch.httpEnabled=true
mail.from=chaimaa.gi@gmail.com
mail.store.host=pop.gmail.com
mail.store.port=995
mail.store.user=chaimaa.gi@gmail.com
mail.transport.auth=false
mail.transport.host=smtp.gmail.com
mail.transport.password=********
mail.transport.port=587
mail.transport.protocol=smtp
mail.transport.username=chaimaa.gi@gmail.com
mail.transport.usetls=true
mailservice.password=********
mailservice.user=chaimaa.gi@gmail.com
nuxeo.csv.blobs.folder=C:/share
nuxeo.data.dir=C:\nuxeo-cap-7.4-tomcat\nxserver\data
nuxeo.db.name=nuxeo74
nuxeo.db.password=********
nuxeo.force.generation=true
nuxeo.templates=postgresql,drive
nuxeo.wizard.done=true
org.nuxeo.dev=false
server.status.key=********

i've attached my log file

FILES:   server.log
0 votes

2 answers

13124 views

ANSWER



Thank you so much Julien Carsique i've finally succeeded to send email . So for those who are looking for settings for SMTP Gmail :

mail.transport.protocol=smtp
mailservice.user=mailfrom@gmail.com
mailservice.password=********
mail.transport.port=587
mail.transport.auth=true
mail.from=mailfrom@gmail.com
mail.transport.host=smtp.gmail.com
mail.transport.password=********
mail.transport.usetls=true
mail.transport.user=mailfrom@gmail.com
0 votes



Give a look at Nuxeo-Connexion-to-SMTP-Google-Mail-GMail, it may help.

Please paste the output of ./bin/nuxeoctl showconf to share your effective configuration.

Also, aren't there some errors in the server logs? Paste them too please.

0 votes



Julien Carsique can you see my update ?
10/21/2015

Yes, thanks
10/21/2015

Have you followed https://support.google.com/mail/answer/14257 ? Especially https://www.google.com/settings/security/lesssecureapps or, if using two-factor auth, https://security.google.com/settings/security/apppasswords ?

I'm not sure about mail.transport.auth=false

For Thunderbird, I had to use: smtp.googlemail.com and port 465. If the above lesssecureapps link does not fix the issue, then you can give a try with those alternate parameters.

10/21/2015

Thank you Julien Carsique , i've tried those links , but it's still not working, can you post the whole configuration ?
10/30/2015

Maybe is it related to https://jira.nuxeo.com/browse/NXP-18363

Can you try to also add mail.transport.user=chaimaa.gi@gmail.com ?

11/19/2015