compiling https://github.com/nuxeo/nuxeo-web-ui fails

I cloned the mentioned repo and want to continue with the next step “npm install”. Unfortunately the NPM repo seems to be outdated because a package is missing.

npm ERR! Linux 4.15.0-60-generic
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! node v8.10.0
npm ERR! npm  v3.5.2
npm ERR! code E404

npm ERR! 404 Not found : @nuxeo/page
npm ERR! 404 
npm ERR! 404  '@nuxeo/page' is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
npm ERR! 404 It was specified as a dependency of '@nuxeo/nuxeo-web-ui'
npm ERR! 404 
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

What I am missing?

0 votes

1 answers

87 views

ANSWER



I think it's particular about the version of node and npm. Try with these: node v10.12.0 and npm 6.4.1

0 votes



Hm, did you recently (today) had success to retrieve the package with the versions of node and npm you mentioned? I could not even find it with a browser. Please check https://www.npmjs.com/search?q=%40nuxeo%2Fpage
09/06/2019

Sorry, I missed the 11.1 tag in your post. I have success with the 10.10 branch but not 11.1 or master.
09/06/2019