Static war with PostresSQL returns exception when use the CMIS interface

Hi community, I have created a test system with a Nuxeo community server and a PostgreSQL database. The test server works fine under my user account on a Suse Linux. Now I will generate a static war to deploy to a development server. The installation of the static war works but when I access the Server with the CMIS workbench, I receive an exception and no property information is sendet. In the server log file I see an exception stack trace:

aused by: java.lang.NullPointerException

at org.nuxeo.common.utils.FileUtils.getFilePathFromUrl(FileUtils.java:325)
at org.nuxeo.common.utils.FileUtils.getResourcePathFromContext(FileUtils.java:387)
at org.nuxeo.common.utils.FileUtils.getResourceFileFromContext(FileUtils.java:392)
at org.nuxeo.ecm.platform.thumbnail.factories.ThumbnailDocumentFactory.getDefaultThumbnail(ThumbnailDocumentFactory.java:117)
at org.nuxeo.ecm.platform.thumbnail.factories.ThumbnailDocumentFactory.getThumbnail(ThumbnailDocumentFactory.java:69)
at org.nuxeo.ecm.core.api.thumbnail.ThumbnailServiceImpl.getThumbnail(ThumbnailServiceImpl.java:93)
at org.nuxeo.ecm.platform.thumbnail.rendition.ThumbnailRenditionProvider.render(ThumbnailRenditionProvider.java:45)
at org.nuxeo.ecm.platform.rendition.impl.LiveRendition.computeRenditionBlobs(LiveRendition.java:62)
at org.nuxeo.ecm.platform.rendition.impl.LazyRendition.getBlobs(LazyRendition.java:60)
at org.nuxeo.ecm.platform.rendition.impl.LazyRendition.getBlob(LazyRendition.java:50)
at org.nuxeo.ecm.core.opencmis.impl.server.NuxeoObjectData.getRenditionServiceRenditions(NuxeoObjectData.java:469)
at org.nuxeo.ecm.core.opencmis.impl.server.NuxeoObjectData.getRenditions(NuxeoObjectData.java:355)
at org.nuxeo.ecm.core.opencmis.impl.server.NuxeoObjectData.getRenditions(NuxeoObjectData.java:344)
at org.apache.chemistry.opencmis.commons.impl.JSONConverter.convert(JSONConverter.java:1181)
at org.apache.chemistry.opencmis.server.impl.browser.ObjectService$GetObject.serve(ObjectService.java:641)
at org.apache.chemistry.opencmis.server.shared.Dispatcher.dispatch(Dispatcher.java:92)
... 59 more.

Have you a tipp?

Ralf Lange Dresden, Germany

0 votes

3 answers

209 views

ANSWER



Hi Gildas, thanks for your answer to my question. I change in the webapps directory the directory name from 'nuxeo' to 'nuxeo.war'. Than I have also to change the URL for the user to server:8080/nuxeo.war/ui and the web user interface can't find some other resources (background files, logos, …). Also it is not possible to connect via CMIS to the server. Than I change the name of the directory back to 'nuxeo' and create a second directory 'nuxeo.war' and copy the img directory in this directory. But this is also not a solution for the problem. Now I need a new idea. :-)

Ralf

0 votes



Hi Ralf,

In the folder webapps, can you try to rename the nuxeo folder into nuxeo.war? Then, the path nuxeo.war/icon/domain.gif should be found.

0 votes



I looking in the sources and in the ThumbnailDocumentFactory.getDefaultThumbnail line 117 I see:

File iconFile = FileUtils.getResourceFileFromContext(“nuxeo.war” + File.separator + iconPath);

In the community server the directory “nuxeo.war” exists in the dirctory “nxserver” and so all works fine. In the static war is no directory “nuxeo.war” and so the call of getResourceFromContext with the argument “nuxeo.war/img/domain.gif” fails. An quick fix can be to create a directory “nuxeo.war” with all image files in the static war installaton but I don't no where is the right position. Have enybody an idea for the right position?

Thanks Ralf Lange

0 votes