Server hangs when trying to start

I just installed cap-5.8-tomcat on a machine running cap-5.5-tomcat which after upgrading the java version to 1.7 seems to work, but then hangs up for a long time after it says server started with PID …. and then says some commands failed to run.

Where would I check to see what is failing when I try to start the server?

Update:

Server is starting now (was an incorrect port in the nuxeo.conf).

Now I am getting this as a result of logging in:

Context


Request Attributes:

nuxeo.disable.redirect.wrapper : true
user_message : An unexpected error occurred. Click on the following links to get more information or go back to the application.
NuxeoExceptionHandlerMarker : true
exception_message : Can't find anonymous user id
securityError : false
messageBundle : java.util.PropertyResourceBundle@161da59f
stackTrace : javax.servlet.ServletException: Can't find anonymous user id
    at org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter.getAnonymousId(NuxeoAuthenticationFilter.java:672)
    at org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter.doFilterInternal(NuxeoAuthenticationFilter.java:525)
    at org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter.doFilter(NuxeoAuthenticationFilter.java:406)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
    at org.nuxeo.ecm.platform.web.common.requestcontroller.filter.NuxeoCorsFilter.doFilter(NuxeoCorsFilter.java:51)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
    at org.nuxeo.ecm.platform.web.common.exceptionhandling.NuxeoExceptionFilter.doFilter(NuxeoExceptionFilter.java:79)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
    at org.nuxeo.ecm.platform.web.common.encoding.NuxeoEncodingFilter.doFilter(NuxeoEncodingFilter.java:69)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:502)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408)
    at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1023)
    at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
    at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:312)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
0 votes

1 answers

1977 views

ANSWER

Please describe the environment: OS, database…

Also look at the nuxeoctl, console and server logs.

09/29/2014

Environment is this:

Debian 7 64bit with PostgreSQL 9.1 and Java 1.7 and 1.8 (I tried to upgrade to 1.8 first, but Nuxeo would not run with it).

09/29/2014



Hi,

If you find no relevant log, then the first step is to start the server in console mode: nuxeoctl console.

See ADMINDOC/Launcher+Says+It+Couldn't+Retrieve+Process+ID for a few debugging tips.

0 votes



ADMINDOC/Logs+Analysis lists and describes the logs files.
09/29/2014

Thank you so much for the information. I will look into it and see what I find.
09/29/2014

It seems that after I got the server started, it is unable to connect to authentication database. What is the best way to debug this?
09/29/2014

First thing is to try a manual connection with the same credentials and parameters. Increasing the log level to DEBUG on org.nuxeo.runtime.datasource may help.

You can also set nuxeo.db.jdbc.url=jdbc:postgresql://${nuxeo.db.host}:${nuxeo.db.port}/${nuxeo.db.name}?loglevel=2 in nuxeo.conf but that can be verbose!

09/30/2014

I do not mind verbose. I would like to find out why this is happening. I will try this later today or tomorrow, and see what I find.
09/30/2014