Active Directory Authentication

Hi All

I followed the documentation: http://doc.nuxeo.com/display/ADMINDOC/Using+a+LDAP+directory and I get this error on startup:

2013-07-16 04:50:04,127 INFO [org.jboss.seam.servlet.SeamFilter] Initializing filter: org.jboss.seam.web.exceptionFilter 2013-07-16 04:50:04,127 INFO [org.jboss.seam.servlet.SeamFilter] Initializing filter: org.jboss.seam.web.multipartFilter 2013-07-16 04:50:04,834 ERROR [org.nuxeo.ecm.platform.web.common.requestcontroller.filter.NuxeoRequestControllerFilter] Unable to get RequestControllerManager service 2013-07-16 04:50:04,835 ERROR [org.nuxeo.ecm.platform.web.common.requestcontroller.filter.NuxeoRequestControllerFilter] Unable to get RequestControllerManager service 2013-07-16 04:50:04,836 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/nuxeo].[Nuxeo Status Servlet]] Servlet.service() for servlet Nuxeo Status Servlet threw exception java.lang.NullPointerException at org.nuxeo.ecm.platform.web.common.exceptionhandling.NuxeoExceptionFilter.getHandler(NuxeoExceptionFilter.java:62) at org.nuxeo.ecm.platform.web.common.exceptionhandling.NuxeoExceptionFilter.handleException(NuxeoExceptionFilter.java:73) at org.nuxeo.ecm.platform.web.common.exceptionhandling.NuxeoExceptionFilter.doFilter(NuxeoExceptionFilter.java:82) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.nuxeo.ecm.platform.web.common.encoding.NuxeoEncodingFilter.doFilter(NuxeoEncodingFilter.java:59) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859) at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:602) at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489) at java.lang.Thread.run(Thread.java:724)

I enabled logging (per docs page) and do see that LDAP component is activated:

2013-07-16 05:47:00,781 INFO [org.nuxeo.runtime.model.impl.ComponentRegistry] Registering component: service:org.nuxeo.ecm.directory.ldap.management 2013-07-16 05:47:00,782 INFO [org.nuxeo.runtime.model.impl.RegistrationInfoImpl] Component activated: service:org.nuxeo.ecm.directory.ldap.management

If relevant, I'm connecting to Active Directory. The Known Issues suggestion doesn't seem relevant, since I'm installing 5.7.1, plus I don't want to manage groups in LDAP, only users/authentication. I'm not getting any traction in debugging the problem. My config is here: http://pastebin.com/Mf4gN6YG Any help is greatly appreciated.

-Trey

0 votes

0 answers

854 views

ANSWER

Did you add in LDAP-specific DEBUG to log4j.xml? This will help with a more specific AD-related error message.

<category name="org.nuxeo.ecm.directory">
   <priority value="DEBUG" />
</category>
07/16/2013

Hi,

I'm not sure the LDAP/AD config has (directly) something to do with the error being a servlet initialization issue…

The pastebin link seems broken.

Is this the first logged issue at startup? Don't you get a components loading status?

07/17/2013