Problem with installing Nuxeo on Debian

Hi everybody, After installing on my computer (an Ubuntu 16.04). I want to install the same thing on the server of the company using the same command line installation protocol since it had worked the first time. https://doc.nuxeo.com/nxdoc/installing-the-nuxeo-platform-on-linux/ I use a debian 9.0

Only, I have a problem from the first line: wget -q -O- http://apt.nuxeo.org/nuxeo.key | sudo apt-key add - that worked on an Ubuntu does not seem to work on Debian. When I enter after writing the line, it makes me a line and for 1 hour, nothing happens. I tried to continue without this line but logically, it is indispensable.

I would like to know if the protocol on Ubuntu and on Debian are the same as I thought and what is the solution for this line. The other lines seem to work well.

I put the screenshot of the worries

Thank you in advance.

0 votes

1 answers

2348 views

ANSWER



Hello,
The screenshot does not match your above text, please take care to describe the exact steps and outputs.
Of course, you're not using sudo while being root.

Did you try to execute the two commands separately?

I reproduced an issue, not sure it is the exact same as you:

# I first had to install wget
$ apt-get update
$ apt-get install wget

# wget is ok
$ wget -q -O- http://apt.nuxeo.org/nuxeo.key

# apt-key is not ok
$ apt-key list
E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation

# Indeed, it seems that apt-key does not depend on a GnuPG implementation and that the gnupg package is not installed by default since Debian sid.
$ apt-get install gnupg

$ wget -q -O- http://apt.nuxeo.org/nuxeo.key|apt-key add -
OK

I tested on a Docker image of Debian Stretch (9.1). I'm updating our documentation about GnuPG on Debian.

0 votes