Automation client authentication for Sql Server users.

We have been stuck at this for sometime. We have configured our nuxeo Installation to retrieve users from the Sql Server DB. We have modified the following config file. default-sql-directories-bundle.xml

After configuring for sql server users we are able to see the users in the admin, user/group section. We are also able to log in using those users on the UI.

But we are not able to get a automation client session using those users. Is there anymore configuration we need? Does it involve some how contributing to org.nuxeo.ecm.automation.server.auth.config extension point? We donot have Nuxeo studio. How can this be done?

This is the error we are getting.

2012-07-23 12:22:47,750 DEBUG [org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter] Entering Nuxeo Authentication Filter 2012-07-23 12:22:47,751 DEBUG [org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter] Principal not found inside Request via getUserPrincipal 2012-07-23 12:22:47,751 DEBUG [org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter] Try getting authentication from cache 2012-07-23 12:22:47,751 DEBUG [org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter] Trying to retrieve userIdentification using plugin AUTOMA TION_BASIC_AUTH 2012-07-23 12:22:47,751 DEBUG [org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter] Trying to retrieve userIdentification using plugin ANONYM OUS_AUTH 2012-07-23 12:22:47,751 DEBUG [org.nuxeo.ecm.platform.ui.web.auth.NuxeoAuthenticationFilter] user/password not found in request, try into identity cac he

Thanks in advance.

0 votes

1 answers



Hi nuxeonovice.

Could you please share me your default-sql-directories-bundle.xml file as an example for a similar configuration (similar to the one you described here: I need to do?

Basically, I need to retrieve users/groups from two SQL Server tables instead of the default setting of Nuxeo.

Your help will be appreciated.


Raúl Chavarría (


Fixed. We were using blank passwords. Blank password cannot be used with automation client. Once we started using non blank passwords, we could signin. Thanks.

0 votes