Nuxeo Drive on Ubuntu Gnome: cannot select sync folders, popup stays empty

I installed Nuxeo Drive 3.0.4 on Ubuntu Gnome 16.04 and am able to connect to my Nuxeo server, authentication works fine. But when I click the button to select the sync folders, the opening popup just remains blank. Any idea what's wrong here? I don't see any error in the log. (I installed Nuxeo LTS2017 / 9.10 via apt, and using the default postgres db).

type an image title

Running “ndrive –log-level-file=TRACE” gives me the following info:

2018-02-08 15:51:23 11325 139739813054208 TRACE    nxdrive.wui.dialog Load web file: /usr/local/lib/python2.7/dist-packages/nxdrive/data/ui5/settings.html
2018-02-08 15:51:24 11325 139739813054208 DEBUG    nxdrive.manager    Will use '/home/mconradt/Nuxeo Drive' as default Nuxeo Drive folder location
2018-02-08 15:51:25 11325 139739259156224 TRACE    nxdrive.client.base_automation_client Response for 'http://localhost:8080/nuxeo/site/automation/NuxeoDrive.GetTopLevelChildren' with cookies [Cookie(version=0, name='X-Authentication-Token', value='ab0d62e6-d6e8-4cf0-9eab-c9407673d229', port=None, port_specified=False, domain=u'localhost.local', domain_specified=False, domain_initial_dot=False, path='/nuxeo', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={}, rfc2109=False)]: '[]'

One thing that's weird is why it says “Will use '/home/mconradt/Nuxeo Drive' as default Nuxeo Drive folder location” when I have set another folder than the default.

Also, this request that is shown in the log, gives the following response:

GET http://localhost:8080/nuxeo/site/automation/NuxeoDrive.GetTopLevelChildren

{
  "id" : "NuxeoDrive.GetTopLevelChildren",
  "label" : "Nuxeo Drive: Get top level children",
  "category" : "Services",
  "requires" : null,
  "description" : "",
  "url" : "NuxeoDrive.GetTopLevelChildren",
  "signature" : [ "void", "blob" ],
}

Not much info in here.

I just installed a fresh Nuxeo LTS 2017 and via WebUI, I can also see all the demo data, i.e. the images.

0 votes

1 answers

611 views

ANSWER

Did you set synchronization on at least one folder (via the browser)?
02/08/2018

OMG how embarrassing. I haven't used Nuxeo for over a year - just getting back into it again - and totally forgot about that I have to enable the folders first on the server. Thanks!
02/08/2018

You are welcome. I added an aswer to be able to that question.
02/08/2018



Be sure to have at least one synchronization root ;)

1 votes