Nuxeo Drive 2.x and Open In Editor directly - configuration?

Having some issues with an existing Nuxeo install - need to replace LiveEdit with Nuxeo Drive/Open in Editor functionality. Setup of Nuxeo Drive is straight-forward on server and client. I can get sync working without issue - across Windows, OSX, and Linux platforms. Clicking the Open in Editor link (on Windows) opens Word with the document in question. I make some edits, click save, and expect changed document to be pushed into repo - but it's not. When I exit Word, return to browser and then re-open the same document, the changes are not present.

After failing with upgrade scenario above, I retired whole process on a brand new instance of 7.4 and the result was the exact same. On this instance I made sure to have latest 9.4 version of postgres installed as well as latest version of java 8.

I've read through all the documentation I could find but to no avail.

Am I missing something here or misunderstanding the capability?

Many thanks, Bruce.

FILES:   nxdrive.log
0 votes

2 answers

1117 views

ANSWER



ataillefer provided the answer in another question …. so, I upgrade to 7.10 and using the 2.0.911 version of Nuxeo Drive client everything magically worked ;-)

“Hello,

Unfortunately there is an issue with versions of Nuxeo Drive > 2.0.911 + Nuxeo 7.4.

Upgrading to 7.10, the latest LTS that has just been published, should solve the issue.

While you're hitting a 7.4 instance, 2.0.911 should work, it is strange that file upload doesn't work in this case, must be another issue…”

0 votes



What's the version of Nuxeo Drive you're using.

Do you see any errors in the logs located in C:\Users\<username>\.nuxeo-drive\logs\nxdrive.log, if so can you please attach an extract?

Thanks.

0 votes



Client&gt; Nuxeo Drive version 2.0.1110 Server&gt; 1.5.3

Log attached (see original question above) with debug on - see one error message

11/16/2015

Thanks.

First you should get rid of this error: 2015-11-16 06:20:30,044 1816 140735301074944 DEBUG nxdrive.engine.dao.sqlite Create main connexion on /Users/brucegrant/.nuxeo-drive/ndrive_0b5cbd408c5411e59968a8206602a62e.db (dir exists: 1 / file exists: 0) 2015-11-16 06:20:31,055 1816 140735301074944 ERROR nxdrive.manager
Traceback (most recent call last): File "nxdrive/manager.pyc", line 906, in bind_engine File "nxdrive/engine/engine.pyc", line 170, in init File "nxdrive/engine/engine.pyc", line 732, in bind RootAlreadyBindWithDifferentAccount

Seems like you are binding 2 separate accounts on the same local folder.

Are you Drive Editing the file connected to the UI as the same user connected through Drive (Administrator in this case)?

In the logs I can see that the file has been uploaded twice: 2015-11-16 06:23:14,837 1816 123145307209728 DEBUG nxdrive.drive_edit Uploading file /Users/brucegrant/.nuxeo-drive/edit/03f62630-7d18-489a-ae9e-51d845469a37/Scheduled Maintenance - 22NOV15.docx

2015-11-16 06:24:16,034 1816 123145307209728 DEBUG nxdrive.drive_edit Uploading file /Users/brucegrant/.nuxeo-drive/edit/03f62630-7d18-489a-ae9e-51d845469a37/Scheduled Maintenance - 22NOV15.docx

11/16/2015

&gt;&gt; Are you Drive Editing the file connected to the UI as the same user connected through Drive (Administrator in this case)?

Yes, is that an issue? Wouldn't a user typically use the same account for both? And wouldn't it be normal to launch edit from with Nuxeo UI?

I got rid of the Error my deleting existing shares and .nx-drive, re-launching and reconnecting. There are now only debug statements - no errors, yet documents are still not updated in Nuxeo.

11/16/2015