AD LDAP Connection Issues

Hi Guys, I have spend pretty much all day trying to get this fixed, I have read pretty much all the dococuments and a number of questions/answers and I am still stumpted with configuring LDAP integration.

This is the guide I have been trying to follow: http://doc.nuxeo.com/display/ADMINDOC/Using+a+LDAP+directory

This is my default-ldap-users-directory-config.xml http://pastebin.com/YL3VSwXh

This is my defaul-sql-directories-bundle.xml http://pastebin.com/VMEJLzVC

This is my server.log (with the error) http://pastebin.com/F151GEez

With this configuration I can still login using the default Administrator Account.

Any suggestions would be most welcome. This is running on a Windows 2008 Server with Tomcat, Nuxeu v4.5.2

Boris

0 votes

2 answers

1137 views

ANSWER



It seems that the LDAP configuration is ignored and Nuxeo is still using the default directory configuration that uses the SQL database. This is a known issue referenced in the documentation:

https://jira.nuxeo.com/browse/NXP-6574 prevents the LDAP contribution from being activated. Quick solution is to put in comments the “” part in templates/common/config/default-sql-directories-bundle.xml (or overwrite that file with a custom template).

0 votes



Thanks Olovier for your reply. When I do that these are the error messages in my server.log

http://pastebin.com/7FNJJUq6

I have also now downloaded the 3x files from the ldap configuration documentation page (the attachments link up top) updated all the ldap connection specific settings and tried using them with the same error as per the server.log

12/08/2011

It seems that the default-ldap-users-directory-config.xml file is not found. Are you sure it is deployed in the nxserver/config/ folder of the running server? You can either put it in the nxserver/config folder the template/default folder or better create your own custom template (you need to configure the templates line in bin/nuxeo.conf if this is the case.
12/08/2011


Hi Borizuka

did you resolve your problem?

I have the same problem. If you resolved it, could you tell me the solution?

Thanks!!

-1 votes



This is not an answer. Please don't post questions in the answers section.
05/16/2012