How to configure mod_sso Proxy Authentication with Nuxeo CMIS?

I am attempting to configure Nuxeo CMIS to use mod_sso Proxy Authentication instead of Basic Authentication. I have mod_sso Proxy Auth successfully configured for the Nuxeo web application. When my CMIS client initially attempts to access the atom/cmis URL, it first receives a 302 response with Location Header …/nxstartup.faces?loginRedirection=true, then it receives another 302 response to …/view_domains.faces?conversationId=0NXMAIN. How should atom/cmis be configured to resolve this issue?

1 votes

1 answers

1089 views

ANSWER



The following solution seems to have a fixed the problem:

  1. Define an additional ProxyAuthenticator authenticationPlugin with parameter ssoNeverRedirect set to true
  2. Define a specificAuthenticationChain for url (.)/atom/cmis. with a replacementChain that references the new authenticationPlugin defined above (1)
0 votes



What would that new component look like?
02/08/2013