Running into Cannot find any valid path in operation chain error with Document.GetPrincipalEmails and Notification.SendMail

I am writing a chain to retrieve the emails of assignees for a workflow node, and send an email to those assignees.

My current chain:

  • Context > Fetch Document
  • Document > Get Principal Emails (retrieve the assignee emails here)
  • Audit > Log
  • Context > Run Script
  • Document > Set Lifecycle
  • Document > Set Property
  • Notification > Send Mail (set the TO property to the assignee emails here)

My chain works fine if I leave out Document > Get Principal Emails (I substitute in a dummy email for testing), but if I run the chain as above, I get the following error stack:

Caused by: org.nuxeo.ecm.platform.routing.api.exception.DocumentRouteException: Error running chain: AssignReview
    at org.nuxeo.ecm.platform.routing.core.impl.GraphNodeImpl.executeChain(GraphNodeImpl.java:523)
    at org.nuxeo.ecm.platform.routing.core.impl.GraphNodeImpl.executeChain(GraphNodeImpl.java:491)
    at org.nuxeo.ecm.platform.routing.core.impl.GraphRunner.runGraph(GraphRunner.java:227)
    at org.nuxeo.ecm.platform.routing.core.impl.GraphRunner.resume(GraphRunner.java:161)
    ... 190 more
Caused by: org.nuxeo.ecm.automation.TraceException: 

****** chain ******
Name: AssignReview
Exception: InvalidChainException
Caught error: Cannot find any valid path in operation chain - no method found for operation 'Notification.SendMail' and for first input type 'org.nuxeo.ecm.core.api.impl.DocumentModelListImpl'
Caused by: null
****** Hierarchy calls ******

    at org.nuxeo.ecm.automation.core.impl.OperationServiceImpl.run(OperationServiceImpl.java:195)
    at org.nuxeo.ecm.automation.core.impl.OperationServiceImpl.run(OperationServiceImpl.java:89)
    at org.nuxeo.ecm.platform.routing.core.impl.GraphNodeImpl.executeChain(GraphNodeImpl.java:515)
    ... 193 more
Caused by: org.nuxeo.ecm.automation.InvalidChainException: Cannot find any valid path in operation chain - no method found for operation 'Notification.SendMail' and for first input type 'org.nuxeo.ecm.core.api.impl.DocumentModelListImpl'
    at org.nuxeo.ecm.automation.core.impl.CompiledChainImpl.buildChain(CompiledChainImpl.java:161)
    at org.nuxeo.ecm.automation.core.impl.ChainTypeImpl.newInstance(ChainTypeImpl.java:130)
    at org.nuxeo.ecm.automation.core.impl.OperationServiceImpl.run(OperationServiceImpl.java:157)
    ... 195 more

Any ideas? It doesn't matter where the Get Principal Emails operation is location the chain, it still throws the error.

I am on the latest hotpatch (HF06).

1 votes

0 answers

1587 views

ANSWER

I have the same message error ("Cannot find any valid path in operation chain"), but in a diferrent situation, and a would like to know what does it means.
02/20/2014

facing the same error in some other issue..will appreciate any resolution to the same
06/23/2016