Unable to connect to remote Nuxeo Server using Nuxeo Shell

After getting into the Nuxeo Shell via Nuxeo's “Admin Center”/“Monitoring”/“Shell” tab, the interactive mode put me in the “remote” namespace. Issuing a connection w/ pw —

remote> connect http://localhost:8080/nuxeo/site/automation -u Administrator

Password: *

But the connection always fails (error msg — Failed to connect to http://localhost:8080/nuxeo/site/automation).

We noticed the following warning in the /var/log/nuxeo/server.log file — 2013-08-15 20:11:12,789 WARN [org.nuxeo.ecm.platform.web.common.requestcontroller.filter.BufferingServletOutputStream]Client disconnected: Broken pipe 2013-08-15 20:11:12,791 WARN [org.nuxeo.ecm.platform.web.common.requestcontroller.filter.BufferingServletOutputStream]Client disconnected : Broken pipe

And looks like even without issuing the “connect” (i.e. just trying to get to Nuxeo Shell) will generate the above “Client disconnected: Broken pipe” message. Anyone out there encountering the same problem? We suspect the above error condition causes our not able to connect to the Nuxeo Server, but we cannot figure out what triggers the warning message. Any help is greatly appreciated.

Yuteh

p.s. going into Nuxeo Shell by http://hostname:port/nuxeo/site/shell also fails on connecting to the server, so this failure mode is not tied to getting in from “admin center”.

2 votes

1 answers

1380 views

ANSWER

I could not reproduce this error on OS X 10.7.5 using cap-5.7.2 and jdk1.7.0_25-b15
08/21/2013



Hi, I have the same issue on nuxeo-5.8, did you solved it ? Thanks

0 votes