How to send email alerts? SMTP settings

Nowhere do I see send email to users and email alerts are not working, is there a way to test if email is working?

I read the documentation and changed the settings in Admin Center | System Information| Setup to no avail… I don't have a send mail next to print.

Is there a way to test a email connections?

I get the following error:

WARN  [Nuxeo-Work-default-1] [org.nuxeo.ecm.platform.ec.notification.NotificationEventListener] Failed to send notification email to 'daniel.d.mendes@icreateconsulting.com': javax.mail.MessagingException: Could not connect to SMTP host: cphost3.rackspot.net, port: 465, response: 421

These are the same settings that I have used in dozens of places including in stuff like alfresco, etc… Here are my settings:

### BEGIN - DO NOT EDIT BETWEEN BEGIN AND END ### Tue Feb 18 19:59:31 GMT 2014
#mail.debug=false mail.debug=true
#mail.transport.auth=false mail.transport.auth=true
#mail.transport.host=localhost mail.transport.host=cphost3.rackspot.net
#mail.transport.password=secret mail.transport.password=****
#mail.transport.port=25 mail.transport.port=465
#mail.transport.user=anonymous mail.transport.user=daniel.d.mendes@icreateconsulting.com
#mail.transport.usetls=false mail.transport.usetls=true
#nuxeo.bind.address=0.0.0.0 nuxeo.bind.address=127.0.0.1
#nuxeo.url=http://localhost:8080/nuxeo nuxeo.url=http://localhost:8088/nuxeo
#org.nuxeo.dev= org.nuxeo.dev=false
#server.status.key= server.status.key=79c10050
### END - DO NOT EDIT BETWEEN BEGIN AND END ###

I also tried to use gmail settings but that did not work either… I am now installing an SMTP server to see if it's a firewall issue, but that seems unlikely since the same seetings work on other systems.

Right now this is the only thing stopping us from useing nuxeo :(

0 votes

2 answers

3301 views

ANSWER



The error includes:

Could not connect to SMTP host: cphost3.rackspot.net, port: 465, response: 421

SMTP error 421 is “Try again later” which may be due to server overload or too many connections (typically) open from your host.

1 votes



I actually figured it out. Ill write up the anwser later. Thanks!
03/18/2014


You can try to run the unit tests in module nuxeo-features/nuxeo-platform-mail/nuxeo-platform-mail-core, then customize them to match your parameters. It will be easier to setup and debug, and faster, than playing with the server. At least, you should be able to reproduce your issue in a unit test.

We do have functional and integration tests on the mail feature, playing with mail.transport.port, mail.transport.host, mail.transport.protocol, mail.transport.usetls, mail.transport.auth, mail.transport.user and mail.transport.password properties, as far as I know they work fine. However, there are sometimes some tricky configuration (TLS, AUTH, …) with custom servers, or even Google mail.

If you want to setup such a high-level test, look at the nuxeo-distribution/nuxeo-distribution-dm/ftest module and setup environment properties (MAIL_TRANSPORT_HOST, MAIL_TRANSPORT_PORT, MAIL_TRANSPORT_PROTOCOL, MAIL_TRANSPORT_USETLS, MAIL_TRANSPORT_AUTH, MAIL_TRANSPORT_USER and MAIL_TRANSPORT_PASSWORD) to get the tested server being automatically configured.

1 votes



Julien,

I have tried 3 diferent SMTP provideers, 9 diferent authentications and still no sucess if it's not one error it's another. I am going simply crazy with this.

Tested with SMTP Test Tool here is the log:

Connecting to mail server.
Connected.
220-cphost3.rackspot.net ESMTP Exim 4.82 #2 Tue, 18 Mar 2014 20:16:15 +0000 
220-We do not authorize the use of this system to transport unsolicited, 
220 and/or bulk e-mail.
EHLO KP120402
250-cphost3.rackspot.net Hello a95-92-225-106.cpe.netcabo.pt [95.92.225.106]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
AUTH LOGIN
334 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX==
334 XXXXXXXXXX=
235 Authentication succeeded
RSET
250 Reset OK
MAIL FROM: <daniel.d.mendes@icreateconsulting.com>
250 OK
RCPT TO: <danielmd3000@gmail.com>
250 Accepted
DATA
354 Enter message, ending with "." on a line by itself
.
250 OK id=1WQ0Qq-002USh-Ar
Forcing disconnection from SMTP server.
QUIT
Disconnected.
221 cphost3.rackspot.net closing connection

Message Sent Successfully

Inside of nuxeo I simply cannot get e-mail to work!

03/18/2014

Please be careful when including such network traces. It included your password in base64. I redacted it but on the off-chance that someone saw it or sees it in some archive you should change it.
03/18/2014

I will change it… Thanks.
03/18/2014