Create document with template

Hi,

I create a document type “Custom” in Studio. I create a template with ODT file and available for “Custom” (test with “All” too).

When i create a new document (type “custom”), they are no field “template”. Why ?

After many test, the field template is never displayed on “create document layout” (goal : https://doc.nuxeo.com/display/NXDOC/Template+Rendering+Addon#TemplateRenderingAddon-Creatingadocumentbasedonatemplate)

Thank for your reply.

0 votes

2 answers

970 views

ANSWER



Hi Alexandre,

Two steps to do so in Nuxeo Studio.

First, go to Settings & Versioning > Registries > Layouts and reference the file layout.

{
  layouts: {
    file: "File Layout"
  }
}

type a image title

Then go to your document type. In the creation layout, open the external layouts section. Add the file layout. Save. type a image title

That's it :)

1 votes



Hi, M. Chauvin. Thanks for your post. It work fine.

0 votes