Document types defined in package not visible in the "add content" popup

Hi,

I have a Nuxeo server running inside a Docker container, accessed on the web UI.

I am trying to develop a package to define new document types.

I created a multi-module project using command nuxeo bootstrap multi-module then a package using nuxeo bootstrap package, then added contributions using nuxeo bootstrap contribution. I build my package with mvn clean install, then install it on the server with nuxeoctl mp-install <package_path>.

I first defined a vocabulary by creating a CSV file then extending point “directories” of “org.nuxeo.ecm.directory.GenericDirectory”. This is working fine, I can see the new vocabulary in web UI “Administration/Vocabularies” tab.

Then I tried defining a new schema with just a string element and the vocabulary that I created. I wrote a xsd file and extended point “schema” of “org.nuxeo.ecm.core.schema.TypeService”.

Then I extended point “doctype” of “org.nuxeo.ecm.core.schema.TypeService” to define the new document type. I made it extend Folder and added a few schemas and facets. I also redefined Workspace with append="true" to add the new document type to its subtypes.

Then I extended point “types” of “org.nuxeo.ecm.platform.types.TypeService”, defined my type using the new document type name as ID, set a label, a description, used “view_documents” as default view, set the icon and big icon, used “Collaborative” for the category, and set the “heading” layout for mode “any”.

After all that, I thought that I could create a document of the new document type from a workspace, but I still only see the default types… What am I missing ? I've been trying everything for three days, if you have any help that would be great.

Thanks

0 votes

1 answers

119 views

ANSWER



Ok I figured it out, I wrote a comment before the <?xml version="1.0"?> tag in the doctype contribution, it worked when I removed it.

0 votes