How to change nuxeo context path

I tried to follow the documentation (http://doc.nuxeo.com/display/ADMINDOC/Changing+context+path ) but the server does not want to start … any idea?

0 votes

1 answers

1113 views

ANSWER

What errors does it give? Without knowing more than "does not start" we can't help, obviously.
04/20/2012

It does not give specific error, that's the problem… it try to start for some minutes, then it stop saying something like "too much time to start, I give up"…

Just to summarize: 1) I change the org.nuxeo.ecm.contextPath=/myapp in $NUXEO_HOME/bin/nuxeo.conf 2) I rename the file $NUXEO_HOME/templates/default/conf/Catalina/localhost/nuxeo.xml into $NUXEO_HOME/templates/default/conf/Catalina/localhost/myapp.xml 3) I remove $NUXEO_HOME/conf/Catalina/localhost/nuxeo.xml 4) I rename the file nuxeo.xml under templates/*-quartz-cluster/conf/Catalina/localhost/

04/20/2012

I'm not sure why the server is not starting with the changes you have made. Have you looked at the server log file?

However, even if it did there will be features that do not work as the context path is still hard-coded in many parts of the source code. You will need to amend the source and make your own build.

Regards,

Sean

04/27/2012

Hi Sean, Could you please tell us where you had to change source code so that we can use variables instead of hardcoded path? Thanks Laurent
04/27/2012

What is your Nuxeo version? What server (Tomcat or JBoss)?

Step 1: did you also looked at all configured URLs using the context path?

Step 2 should no more be required. Step 3 is only for cleanup after multiple failing tests. Step 4 is useless if you don't use the *-quartz* templates.

Sean, there must be no more hard-coded paths in the source code; if you still find some, you're welcome to create Jira issues and contribute some patch on GitHub.

04/30/2012



I tried again, following every steps (even if they are the same I have already tried)…now it works, I cannot say why…thanks in any case.

0 votes