Nuxeo 10 : How to switch language

Hello,

I've installed Nuxeo with the virtual machine (VMBox) onto our server and it works quite well. However, no matter what I try it always outputs english as the default language. I tried multiple devices and browsers with different languages on OS level.

How can I force to switch the Nuxeo language to a different language than english (ie. German) ?

Thanks

2 votes

3 answers

552 views

ANSWER

Does somebody know the answer?
07/26/2019

bump
08/13/2019

Is it possible that you have custom code already overwriting this? Which browser are you using? Are there any errors in the log files when you use a browser that is in German?

On an out-of-the-box Nuxeo 10.10 installation I can easily change the language to German by changing my Google Chrome language settings to German.

If you want to force everyone to use German, a hack would be to copy German translation files to the default.

08/16/2019

I'm not using any custom code. This is pretty much the default image 10.10 virtualbox image with some users created and documents uploaded. Nothing else it touched.
12/02/2019



Nuxeo Web UI is taking the language of your browser. So update your preferences / language if needed

1 votes



Does not work for me. I set up German as default language and everything after log-in is english.
01/09/2020


answer deleted

0 votes



Hello,

you can follow this below steps :

  • Choose Preferences in our profiles .
  • After that, an interface that will display in witch you can switch the Nuxeo language.
0 votes



I dont see "Preferences" in my user settings https://imgur.com/hc8Err0
07/15/2019

The link contains information about preferences: https://doc.nuxeo.com/nxdoc/user-preferences/#
07/15/2019

But I'm not on the JSF UI. Am I out of luck? Do I have to install something else? The docs speak of community language packs which might contain other languages, german for instance.
07/15/2019

Are you using WebUI? WebUI uses the language that the user's browser is using. Or you can override per these directions. https://doc.nuxeo.com/nxdoc/web-ui-managing-translations/
07/16/2019

Yes, I am using WebUI. However on my Mac its all English and on my Coworkers Mac (OS language german and browser language german) its still english. I am unable to force a specific language on my users. How can I do that?
07/18/2019

I have the same problem. The login screen is shown in German. Everything else is English. We are using Web UI. Browser language is German. I'm also using the virtual box image. Any help appreciated.
03/18/2020