Fulltext configuration/capabilities on SQL Server 2008 R2 (Nuxeo DM 5.6)

Hi,

I am facing problems with simple search in Nuxeo : it seems that words in the fulltext.simpletext column are the same as the words written in dc:title and dc:description (without stemming process). Only punctuation is removed.

So when I try to search with a wildcard (* or %) it founds no results if i don't put the entire word (ex: the doc with the terme 'elements' indexed are not found with query 'element*' nor 'element%').

By the way, when querying the server database, fulltext is active, collation is also OK according to the nuxeo documentation and I use the “French” anlyser which is in the “sys.syslangyages” alias column.

  • Here is what I entered in the dc:description field through the web :
    Cette description reprend en théorie les éléments nécessaires pour tester le stemming tel que précisé dans la documentation éditeur. Ai-je fait une erreur, quel sera ou serai le bon résultat

  • Here is the content of the fulltext.simpletext column :
    cette description reprend en théorie les éléments nécessaires pour tester le stemming tel que précisé dans la documentation éditeur ai je fait une erreur quel sera ou serai le bon résultat dossier projet 2

  • Here is my default-repository-config.xml :

     <repository name="default"
              factory="org.nuxeo.ecm.core.storage.sql.ra.PoolingRepositoryFactory">
       <repository name="default">
                <pool minPoolSize="0" maxPoolSize="20"
                  blockingTimeoutMillis="100" idleTimeoutMinutes="10" />
                 <clustering enabled="false" delay="1000" />
         <binaryStore path="" />
        <schema>
          <field type="largetext">note</field>
          <field type="largetext">relatedtext</field>
          <field type="largetext">webp:content</field>
          <field type="largetext">webc:welcomeText</field>
          <field type="largetext">comment:comment</field>
          <field type="largetext">post</field>
          <field type="largetext">mail:mail</field>
        </schema>
        <aclOptimizations enabled="true" concurrentUpdate="false"/>
        <indexing>
          <fulltext analyzer="French">
            <index name="default">
              <field>dc:title</field>
              <field>dc:description</field>
              <field>doc:fichierApplicable/data</field>
              <field>doc:fichierCourant/data</field>
            </index>
            <!-- SQL Server does not support more than one fulltext index per
            table: to add support for multiple fulltext index would required to
            change the datamodel of VCS -->
         </fulltext>
        </indexing>
        <usersSeparator key="," />
        <xa-datasource>net.sourceforge.jtds.jdbcx.JtdsDataSource</xa-datasource>
        <property name="ServerName">*****</property>
        <property name="PortNumber">****</property>
        <property name="DatabaseName">****</property>
        <property name="User">****</property>
        <property name="Password">****</property>
        <property name="UseCursors">true</property>
      </repository>
    </repository>
    
  • Why the wildcards operators are not working ?

  • Is there any bug in my configuration that may explain this problem ?

Thank you for your time :)

0 votes

0 answers

1184 views

ANSWER

How are you doing the query?
05/15/2014