CMIS SOAP Access problem

Until now, CMIS has only been used using the AtomPub binding and works fine. I have also tried the Browser binding that works Now I have to use the SOAP binding and it fails with the following error : http://pastebin.com/HiPU1pz2 (in short : This service does not provide an endpoint address: ObjectService)

I use this URL for connecting, https://XXXXXX/nuxeo/webservices/cmis/RepositoryService?wsdl

I m able to load repositories and it seems there is no authentification problem or any other error server side.

Nuxeo version is 6.0 but it seems I have the same problem on a 5.8 server

What am I doing wrong ?

0 votes

1 answers

1026 views

ANSWER



It really depends on how your CMIS client is configured, but each “endpoint” has a different URL for SOAP. See https://doc.nuxeo.com/display/NXDOC/CMIS#CMIS-SOAP for all URLs.

Really SOAP is slower and more complex to use, and you should stick with Browser Bindings.

0 votes



I do agree about other bindings unfortunately there is no choice for me. The error occurs on Apache's cmis workbench but maybe the client application (I do not manage) handles CMIS SOAP bindings in a better way (!?!)
01/19/2016