Problem with searching nuxeo cmis demo with Fresh docs iOS app

Hi I was testing Fresh Docs iOS app for mobile access to nuxeo content via cmis. Browsing works but I noticed that searching doesn't work. Not sure if it is problem with Fresh Docs or nuxeo. As I understand it Fresh Docs is using cmis and as nuxeo supports cmis so should work.

Otherwise any other recommendation for iOS app for remote access to nuxeo content with working search function?

Thanks.

0 votes

1 answers

855 views

ANSWER



Hi,

Out of the box, I would say the issue is in Fresh Docs since we didn't notice such an issue while testing the CMIS connector. You should contact the editor (Zia Consulting) about your issue. I don't know iOS: are you able to get some logs from the application when it fails to search? Which Nuxeo version did you try with? Are you hosting the Nuxeo server? If so, wasn't there some relevant logs on the server side?

About your second question, there are a lot of CMIS browsers available on Internet for all platforms. All of them will work with Nuxeo if they strictly follow the CMIS standard.
Nuxeo has worked on various mobile solutions (native/generic, based on CMIS or not, …) and one of the current recommendations is to look at the nuxeo-web-mobile project if CMIS is not a constraint (that project uses Nuxeo Automation specific protocol instead of CMIS). If you want to develop your own application, then there's also a Nuxeo toolkit for iOS.

Regards,

1 votes



Thanks for your response. Re Fresh Docs I actually tried it with nuxeo demo, cmis.demo.nuxeo.org. I will try with hosted nuxeo next. Will also have a look at web-mobile.

I will update if problem definitely with Fresh Docs after testing with self hosted.

Regards, Jeff

12/17/2012