Possible bug: Nuxeo doesn't clear the connection pool after 10 minutes

Hi,

We're testing our Nuxeo 6.0 and we've detected that it doesn't clear the connection pool when we use Funkload to benchmark it. After a Funkload test against Nuxeo 6.0 the pool reach his limit and Nuxeo can not accept more connections, it throws an exception. After 20 minutes waiting the connection pool is full yet.

Nuxeo says that active connections is 20. I've configured in nuxeo.conf session.timeout=1, but it doesn't solve the problem.

Do you know why?

Thank you, Gabriel

0 votes

0 answers

1728 views

ANSWER

I think latest Nuxeo versions may not be handling user sessions properly.

If I log to Nuxeo vm, browse to Repository statistics tab in admin center and press repeatedly 'F5', I get the connection pool to its maximum. The counter open connections on the repository also increases with each refresh.

In previous versions connections didn't increase.

I think Session Management changed in Nuxeo 6.0. Is this a bug or the expected behaviour?

02/17/2015

It only happens using Chrome o Firefox. If we add &conversationId=0NXMAIN10 to the URL open connections don't increment. IE9 adds that paramenter. Firefox and Chrome don't.

We also noticed that connecting through JMX IdleTimeoutMinutes is 0 for the pool. It apparently ignores the parameter nuxeo.vcs.idle-timeout-minutes.

02/17/2015

IdleTimeout set to zero was an error in our extension file.

jdbc/nuxeo still has idletimeout equals to zero.

02/18/2015

Modifying datasouces-config.xml.nxftl did the trick for jdbc/nuxeo.

We still don't understand conversationId behaviour and some problems with funkload.

02/18/2015