Mail debug logs activation

Hi all,

I'm facing problems to configure nuxeo to use googlemail smtp after a fresh install of nuxeo 5.5 (another post) but I have not enough information to troubleshoot.

I have activated the mail.debug =true in nuxeo.conf and I imagined that this option would bring me into a more verbose mode but my logs are still the same.

Is there anything else to do to activate this option ?

I did a ubuntu server install based on the repository (no particular installation option) so question is : in which log should go the mail information if option is activated (console.log is the only one I have some information related to my mail problem but is there elsewhere to check ??)

Thanks for any help, I'm really banging my head on my desk….

Snarf

0 votes

2 answers

2542 views

ANSWER



Hello,

You will find log debug information into the $Nuxeo/log/server.log.

The debug option activate into nuxeo.conf will produce all information of SMTP connexion into this log file. For instance:

DEBUG SMTP: useEhlo true, useAuth true
DEBUG SMTP: useEhlo true, useAuth true
DEBUG SMTP: trying to connect to host "smtp.gmail.com", port 587, isSSL false 220 mx.google.com ESMTP cy8sm6658407wib.2
DEBUG SMTP: connected to host "smtp.gmail.com", port: 587
You will not see that into the console as there is a bypass for log level higher than INFO by default.

In addition to set mail.debug=true, you probably also have to set the log level to DEBUG for javax.mail in Log4J configuration (as default level is WARN). In $NUXEO_HOME/lib/log4j.xml, add:

<category name="javax.mail">
  <priority value="DEBUG" />
</category>

About the Admin Center, it's only a graphical helper interface for editing nuxeo.conf.

And be careful this debug logs will be not displayed into the console GUI as default log4j configuration specify to stop logs higher than INFO for CONSOLE.

1 votes



I got nuxeo to send email using my company name..

bjalon, thank you for all of your responses, it helped tremendously!

I did find a couple of inconsistencies with the admin setup screens..

First of all, usetls is not in the mail section.. I didn't see it with the mail settings.. however, if you go down to advanced section, the usetls setting is in there…and, right above it was another setting called mail.user .. mine was set to none. I set that to also be the user account (full gmail address), restarted and success!

I would suggest that those mail associated parameters be moved to be with the mail section so they are properly set (with disclaimers, of course)

Thanks to all for this information exchange, it is very helpful

Don Bauer CTO, KnowGov

0 votes



Thanks for your remark about the parameter order for mail configuration.

I create a ticket and fix that as soon as possible. You can follow the fix resolution here:

https://jira.nuxeo.com/browse/NXP-8656

Again thanks a lot for your feedback.

01/17/2012

https://jira.nuxeo.com/browse/NXP-8656 is now fixed, this modified into the trunk and will be delivered for 5.6 release.

Regards.

01/17/2012