How to hidden the Asset Library in nuxeo DM without uninstall it

Currently, I did the traduction to spanish of “document content routing” component and this does not works well if platform has installed “asset Library” component. When I unistall this “asset library” component, my “content routing” component is loaded in spanish but when I have the component asset library installed, my spanish translation does not overwrite the files in “content routing” component

Now I disabled the DAM button in MAIN TAB overwriting the action in dam component

<action id="dam" link="assets" label="" order="50" enabled="false">

The button is hidden and I deleted the document Asset Library in repository but when the server is restarted, the document Asset Library is recreated

What Can I do?

0 votes

2 answers




You can disable the automatic creation of the Asset Library with the following contribution:

<extension target="org.nuxeo.ecm.platform.content.template.service.ContentTemplateService"

  <postContentCreationHandler name="assetLibraryHandler"
    enabled="false" />

1 votes

it works ok but without the line: <require>org.nuxeo.dam.contentTemplate</require>


Je voudrai masquer le DAM (TAB) pour certains utilisateurs , ainsi pour les utilisateurs non authentifiés ?

0 votes