how do I change the schema for ldap properties?

so I followed the tutorial on how to add custom LDAP fields to the nuxeo UI

it works locally on the nuxeo IDE server, but when I move that to ldap there are issues in resolving properties out of the directory.

the query is performed correctly, I can authenticate and listing entries work. however, all fields are empty. in the log I see

2015-04-17 06:15:51,880 WARN  [http-bio-45.55.153.57-8080-exec-31] [org.nuxeo.ecm.platform.el.DocumentModelResolver] Property not found: user:username
2015-04-17 06:15:51,885 WARN  [http-bio-45.55.153.57-8080-exec-31] [org.nuxeo.ecm.platform.el.DocumentModelResolver] Property not found: user:firstName
2015-04-17 06:15:51,894 WARN  [http-bio-45.55.153.57-8080-exec-31] [org.nuxeo.ecm.platform.el.DocumentModelResolver] Property not found: user:lastName
2015-04-17 06:15:51,897 WARN  [http-bio-45.55.153.57-8080-exec-31] [org.nuxeo.ecm.platform.el.DocumentModelResolver] Property not found: user:company
2015-04-17 06:15:51,899 WARN  [http-bio-45.55.153.57-8080-exec-31] [org.nuxeo.ecm.platform.el.DocumentModelResolver] Property not found: user:email
2015-04-17 06:15:51,907 WARN  [http-bio-45.55.153.57-8080-exec-31] [org.nuxeo.ecm.platform.el.DocumentModelResolver] Property not found: user:username

but as per the tutorial I changed the schema to the one I created:

       <server>default</server>
       <schema>extendedUser</schema>
       <idField>username</idField>

why is the document resolver asking fields out the user schema and how do I fix that?

0 votes

0 answers

847 views

ANSWER