Problem raising events in order to refreshUI

I set up an action in order to dynamically add a facet (including its own schema) to several standard doc types. The automation operation uses the AddFacet operation (backported to LTS2015). A custom tab is associated to my custom facet. The process is working fine except that the UI is not refreshed immediately, I have to change Conversation in order to see my tab. I ve tried to use WebUi.Refresh with the DOCUMENT_CHANGED event, didn 't change anything.

Seam.SaveDocumentInUI works

0 votes

0 answers

257 views

ANSWER

Hello,

If you're using an automation chain on your button, you can give a try by adding the WebUI.Refresh operation (old Seam.fresh) after your facet addition.

Otherwise you will have to check the seam beans handling the UI cache and overriding one of them to force the cache refresh (but its really depending on your use case, where you are in the UI etc)

10/18/2017

Hi,

thanks for your answer.

I ve already tried the Refresh Operation without any success. The seam thing seems quite complicated (this is a studio configuration)

Some kind of workaround i found : i navigate to the custom added by the facet (Navigation.ChangeCurrentTab).

Although the content of the tab does appear, it is not present in the tab list of the document. But when I save the form, the document is (really) refreshed and my custom tab appears.

10/19/2017

It really can depend on where you are (meaning the tabs indeed). If it's in the summary for instance of a document, it should not be a problem to use the UI refresh operation for invalidating caches. I could help better if I had the studio project and see all the content for this feature.

For Studio advanced configuration, if you need more customer support, don't hesitate to see our offers here: http://www.nuxeo.com/products/pricing/. You can contact us for consulting and training here as well: http://www.nuxeo.com/about/contact/

Good for the workaround in all cases, thanks!

10/20/2017