"Content too big" when uploading file using CMIS (Atom binding)

Hi,

I'm trying to upload a quite large file (4493949076 bytes) to a given folder o Nuxeo (5.9.3) using Apache Chemistry (chemistry-opencmis-client-impl 0.10.0) but I get a org.apache.chemistry.opencmis.commons.exceptions.CmisConstraintException: Content too big exception when calling Folder.createDocument.

I tried to upload the same file directly using Nuxeo web UI successfully. The problem seems to be related to CMIS.

Is there any configuration on Nuxeo?

I tried How to change size limit for uploaded files, to no avail.

Edit (2015-07-17)

The largest file size we tried and sucessfully uploaded was 4060218219 bytes.

0 votes

1 answers

3711 views

ANSWER

I'm not sure what could provoke this. Do you have the means to put a breakpoint on the CmisConstraintException exception constructors, in order to find what the caller stack trace is? Note however that Nuxeo 5.9.3 is obsolete and unsupported. You should use the latest Nuxeo 6.0 hotfix, or Nuxeo 7.3 if you're willing to use Fast Track releases.
07/20/2015

Oh right, I'd forgotten that. But we actually subclass this (NuxeoCmisServiceFactory) and make it configurable. I'll give you details tomorrow.
07/20/2015



This can be configured by providing appropriate configuration parameters to the following extension point: http://explorer.nuxeo.com/nuxeo/site/distribution/Nuxeo%20Platform-6.0/viewComponent/org.nuxeo.ecm.core.opencmis.bindings.NuxeoCmisServiceFactoryManager

Example:

<extension point="factory" target="org.nuxeo.ecm.core.opencmis.bindings.NuxeoCmisServiceFactoryManager">
  <factory class="org.nuxeo.ecm.core.opencmis.bindings.NuxeoCmisServiceFactory"/>
  <parameter name="service.maxContentSize">4294967296</parameter>
</extension>
0 votes



Florent Guillaume, is this configuration available on 5.9.3 by any chance?
07/22/2015

No, it's only available since Nuxeo 6, see NXP-14362.
07/22/2015