CMIS Nuxeo and SSO

Hello ,

I want to test CMIS wsdl via SoapUI.

My nuxeo instance have SSO authentification .

When i try to get a response form the webservices ( i put a virtual user in my request) , it's return the html code of login page .

Any idea ? thanks

0 votes

2 answers

751 views

ANSWER



I will try to change order .

My actual order is :

    <authenticationPlugin name="PROXY_AUTH">
        <loginModulePlugin>Trusting_LM</loginModulePlugin>
            <parameters>
                XXX
            </parameters>
    </authenticationPlugin>
</extension>
<!-- Include Proxy Auth into authentication chain -->
<extension target="org.nuxeo.ecm.platform.ui.web.auth.service.PluggableAuthenticationService" point="chain">
    <authenticationChain>
        <plugins>
            <plugin>PROXY_AUTH</plugin>
            <!--  Keep basic Auth at top of Auth chain to support RSS access via BasicAuth -->
            <plugin>BASIC_AUTH</plugin>
            <plugin>FORM_AUTH</plugin>
        </plugins>
    </authenticationChain>
</extension>
0 votes



Hi

i do not know what kind of Authentication service you want to use but you should have a look at the order of your plugins in the “chain” extension point of “org.nuxeo.ecm.platform.ui.web.auth.service.PluggableAuthenticationService”.

For instance, if you want to use HTTP Auth for CMIS and Shibboleth for UI, you should have something like :

<extension target="org.nuxeo.ecm.platform.ui.web.auth.service.PluggableAuthenticationService" point="chain">
    <authenticationChain>
        <plugins>
            <plugin>BASIC_AUTH</plugin> 
            <plugin>SHIB_AUTH</plugin> 
        </plugins>
    </authenticationChain>
</extension>
0 votes