Cannot hot deploy bundles, please restart

Hi,

I am running into this error below in Eclipse. I'm using SDK 6.0.

This error shows right when I start Tomcat. I can't figure out how to fix this. I tried:

  • Fresh SDK
  • Fresh workspace
  • Reload project
  • Reinstall Nuxeo plugin

No luck so far. Any idea ?

java.lang.ClassCastException: org.eclipse.core.internal.resources.Project cannot be cast to org.eclipse.core.resources.IFolder
at org.nuxeo.ide.sdk.java.ProjectDeployer.devbundleFolder(ProjectDeployer.java:75)
at org.nuxeo.ide.sdk.java.ProjectDeployer.<init>(ProjectDeployer.java:59)
at org.nuxeo.ide.sdk.java.ProjectDeployer.copy(ProjectDeployer.java:71)
at org.nuxeo.ide.sdk.deploy.Deployment.getContentAsString(Deployment.java:155)
at org.nuxeo.ide.sdk.server.ServerController.writeDevBundles(ServerController.java:217)
at org.nuxeo.ide.sdk.NuxeoSDK.reloadDeployment(NuxeoSDK.java:296)
at org.nuxeo.ide.sdk.server.ui.ServerView.start(ServerView.java:99)
at org.nuxeo.ide.sdk.server.ui.ServerView.debug(ServerView.java:112)
at org.nuxeo.ide.sdk.server.ui.DebugServer.run(DebugServer.java:37)
at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:253)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:595)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:511)
at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java:462)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4454)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1388)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3799)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3409)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:135)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
0 votes

1 answers

1445 views

ANSWER

Just tried to update the current SDK and also use the one you provided. The error is the same.
12/29/2014

In my source folder there is a folder:

bin/devbundle/main/META-INF/

It is created by Eclipse and it is empty. I tried to delete it and it gets re-created. Could that be it?

12/29/2014



Found the issue. The problem comes from the .classpath. Some path were wrong.

Now fixed, the server start just fine.

0 votes