"Cannot hot deploy bundles, please restart" error occurs in Tab Nuxeo Sever

When I install Nuxeo IDE , Nuxeo SDK and Nuxeo platform 7.2 (I think it's necessary to install all these parts to develop software on Nuxeo). Then on the Nuxeo Sever tab I try to start the sever. Unluckily an dialogue box pops up showing the content that

Cannot hot deploy bundles, please restart

**java.lang.NullPointerException

at org.nuxeo.ide.connect.RepositoryManager.deploymentChanged(RepositoryManager.java:136)
at org.nuxeo.ide.sdk.NuxeoSDK.fireDeployementChanged(NuxeoSDK.java:170)
at org.nuxeo.ide.sdk.NuxeoSDK.reloadDeployment(NuxeoSDK.java:295)
at org.nuxeo.ide.sdk.server.ui.ServerView.start(ServerView.java:99)
at org.nuxeo.ide.sdk.server.ui.ServerView.start(ServerView.java:108)
at org.nuxeo.ide.sdk.server.ui.StartServer.run(StartServer.java:37)
at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:251)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java:452)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4170)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:140)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:611)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)**

Have I install Nuxeo IDE and Nuxeo SDK corretly? Because I find a similar question here link:Qustion which doesn't work for me.

How to solve this problem??

0 votes

1 answers

1340 views

ANSWER



Today I find the answer to the question. The reason of this error is that I don't deploy a bundle on the sever before.

0 votes