Setup Elasticsearch Error

I followed the steps provided in the documentation trying to setup the elasticsearch, once done I've tried to browse the elascticsearch section from the admin tab. When I click on it an error is triggered.

Here's my entire log

Elasticsearch configuration in nuxeo.conf:

##-----------------------------------------------------------------------------
## Elasticsearch configuration
##-----------------------------------------------------------------------------
## Enable or disable Elasticsearch integration, default is true.
#elasticsearch.enabled=false
## Remote elasticsearch cluster to join, comma separated list of nodes,
##  if empty use an embedded server, not for production !
#elasticsearch.addressList=localhost:9300
elasticsearch.addressList=localhost:9300
## Remote elasticsearch cluster name to join.
#elasticsearch.clusterName=elasticsearch
elasticsearch.clusterName=elasticsearch-nuxeo-dev
## Name of the Elasticsearch index for the default document repository
#elasticsearch.indexName=nuxeo
elasticsearch.indexName=nuxeo
## Number of replicas (not for embedded mode)
#elasticsearch.indexNumberOfReplicas=1
elasticsearch.indexNumberOfReplicas=0
## Display Elasticsearch cluster and nodes information in admin center
## default is false (always true for embedded mode)
#elasticsearch.adminCenter.displayClusterInfo=true

## Embedded elasticsearch server accept HTTP request on port 9200
##  use this for debug purpose only this is unsecure, default is false.
#elasticsearch.httpEnabled=true

## Comma separated list of CorePageProvider to supersede by Elasticsearch.
##  default is default_search.
#elasticsearch.override.pageproviders=default_search,document_content,section_content,document_content,tree_children,default_document_suggestion,simple_search,advanced_search,nxql_search,DEFAULT_DOCUMENT_SUGGESTION

## Enable or disable Elasticsearch as a backend for audit logs, default is false
audit.elasticsearch.enabled=true
1 votes

1 answers

3244 views

ANSWER

Doyou confirm you are using Nuxeo Platform 7.3?
07/09/2015

Yes I confirm I'm using 7.3
07/09/2015



Hi, I need some more information to help you: Is this a migration of an existing instance to 7.3 or a fresh 7.3 instance ? Have you customized the Elasticsearch mapping ? What is the version of your Elasticsearch instance ?

Regards ben

0 votes



I'm using a fresh instance of Nuxeo 7.3, elasticsearch 1.5.2 and about the mapping are you talking about the elasticsearch-config.xml.nxftl file? I'll update the post and attach it.
07/09/2015

ben
Yes, please provide the elasticsearch-config.xml.nxftl file, if you have customized the file.
07/09/2015

ben Yeah I updated the post and attached the elasticsearch-config.xml.nxftl file. Thanks for the feedback
07/10/2015

ben
Thanks, the content of your file is exactly the same as the default contrib, can you first try to not override the Elasticsearch config. When it works you have to either remove the "requires" either rename your contribution to something like my-elasticsearch-config.xml.nxftl.
07/10/2015

Dalal did you solve your problem?
07/21/2015

aescaffre Yeah it worked only if I disable the elasticsearch backend audit; audit.elasticsearch.enabled=false elseways same issue.
07/21/2015