Nuxeo-Elasticsearch: There was an error communicating with the server, status: 500

Hi,

I can not access to Elasticsearch from Nuxeo GUI (http://nuxeoserver:8080/nuxeo/nxadmin)

“Admin Center -> Elasticsearch”

when I click on Elasticseach the error below is triggered :

(There was an error communicating with the server, status: 500)

I have two servers

server1 –> nuxeoserver

server2 –> elasticserver

when I run :curl -XGET 'http://elasticserver:9200/_cluster/health?pretty=true',

on nuxeoserver or elasticserver, it works:

name “node-1”

cluster_name “cluster01”

cluster_uuid “gPBYisiXSaeoPnO6MrW0Hg”

version

number “6.2.3”

build_hash “c59ff00”

build_date “2018-03-13T10:06:29.741383Z”

build_snapshot false

lucene_version “7.2.1”

minimum_wire_compatibility_version “5.6.0”

minimum_index_compatibility_version “5.0.0”

tagline “You Know, for Search”

Elasticsearch configuration in nuxeo.conf: ..

elasticsearch.addressList=elasticserver:9300

elasticsearch.clusterName=cluster01

elasticsearch.indexName=nuxeo

elasticsearch.indexNumberOfReplicas=0

audit.elasticsearch.indexName=${elasticsearch.indexName}-audit

seqgen.elasticsearch.indexName=${elasticsearch.indexName}-uidgen

..

I have no idea how to resolve this issue. thanks.

0 votes

3 answers

398 views

ANSWER



What nuxeo version are you using? If you are certain you can access elasticserver:9200 from nuxeoserver then perhaps try the elastic restclient instead of transport client. In nuxeo.conf:

elasticsearch.addressList=elasticserver:9200
elasticsearch.client=RestClient

I am assuming you are not using X-Pack with security turned on.

0 votes



thank you James,

I tried Elasticsearch 5.6.3 and Elasticsearch 5.6.4 I have the same issue.

0 votes



Nuxeo currently works with Elastic 5.6.4, it looks like you are using Elastic 6.2.3. See the docs https://doc.nuxeo.com/nxdoc/elasticsearch-setup/

0 votes