Getting Nuxeo 5.5 source code

I used the instructions to get Nuxeo 5.5 source code from Github (http://doc.nuxeo.com/display/CORG/Getting+the+Nuxeo+source+code) :

  • I installed Git client

  • I ran the following commands :

  • git clone git://github.com/nuxeo/nuxeo.git

  • cd nuxeo

  • git checkout master

Till now it worked But when I try to retrieve the release 5.5 with the following python command it fails : python clone.py release-5.5

It return the following exception :

  **File "clone.py", line 65
    except ExitException, e:
                        ^
SyntaxError: invalid syntax**

I made the test under Windows (7 64 Bits) and Linux (CentOS 5.8 64 Bits) and the result is the same. Any idea?

Regards

Laurent

0 votes

2 answers

1051 views

ANSWER



Hi,

Which Python version did you install? We recommend to install Python 2.7.x.

Regards,

0 votes



I made a new test with Pyhton 2.7.3 and now I got the following exception :

Traceback (most recent call last):
  File "clone.py", line 74, in <module>
    main()
  File "clone.py", line 56, in main
    repo = Repository(os.getcwd(), options.remote_alias)
  File "c:\LDT\Projects\Nuxeo\sources\nuxeo\scripts\nxutils.py", line 45, in __init__
    assert_git_config()
  File "c:\LDT\Projects\Nuxeo\sources\nuxeo\scripts\nxutils.py", line 356, in assert_git_config
    t = check_output(["git", "config", "--get", "color.branch"])
  File "c:\LDT\Projects\Nuxeo\sources\nuxeo\scripts\nxutils.py", line 346, in check_output
    p = subprocess.Popen(cmd, stdin=subprocess.PIPE, stdout=subprocess.PIPE)
  File "C:\LDT\Softs\Python-2.7.3\lib\subprocess.py", line 679, in __init__errread, errwrite)
  File "C:\LDT\Softs\Python-2.7.3\lib\subprocess.py", line 896, in _execute_child
    startupinfo)
WindowsError: [Error 2] Le fichier spÚcifiÚ est introuvable`

Regards Laurent

09/10/2012

Ok. This one is a very different issue, Windows specific. It may happen for various reasons, the most common one being a PATH issue with a conflict between multiple Git versions.

Check you don't have Cygwin in your PATH or at least, it is at the end of the PATH. The Git client you installed separately must be the one used by the script clone.py.<br/> If that doesn't fix the issue, then please fill another dedicated question but first look at the following existing answers found by Google search "Nuxeo python subprocess.Popen":

09/10/2012

I installed Pyhton 2.7 and I added pyhton and Git pah before Cygwin PATH on my machine and now it works ;) Thanks a lot

Laurent

10/01/2012


If you work on Windows with MSysGit, you will also encounter a message saying that .git can't be found while trying to run clone.py. In that case, go for version 5.7 that provides a workaround with option –no_drive_mapping. See the documentation update in Getting the Nuxeo source code

0 votes