Unit test not loading custom document type

I have got this error

java.lang.IllegalArgumentException: DR_DRF is not a registered core type

My test class is like:

@RunWith(FeaturesRunner.class)
@Features({RuntimeFeature.class, PlatformFeature.class, CoreFeature.class})
@RepositoryConfig(init = DefaultRepositoryInit.class, cleanup = Granularity.METHOD)
@Deploy({"com.bigcorp.contractmgt.contract-mgt-project-core", "studio.extensions.workflow-dr-eduardo"})
...

I can see in the logs that it seems the module is not loading properly.

The document type exists and can be seen at the images attached

I've also tried with prefix

18:34:22,250 ERROR [OSGiRuntimeService] Nuxeo Platform Started
======================================================================
= Component Loading Status: Pending: 1 / Unstarted: 0 / Total: 100
* service:studio.extensions.workflow-dr-eduardo requires [service:org.nuxeo.ecm.directory.sql.storage]

After some research I have tried to add @Deploy({"org.nuxeo.runtime",

And got this error

Suppressed: org.osgi.framework.BundleException: Failed to start bundle at: /Users/eduardo/Documents/nuxeo-cap-8.3-tomcat-sdk/nxserver/bundles/nuxeo-runtime-8.3.jar with activator: org.nuxeo.runtime.osgi.OSGiRuntimeActivator

What am I missing?

Nelson Silva

Tks Eduardo

0 votes

1 answers

167 views

ANSWER



With help from Frédéric I managed to address this.

This link contains the initial setup to test with Documents

https://github.com/fvadon/nuxeo-labs-dam-studio-test

0 votes