no ddl VCS configuration not working in nuxeo EP 5.5

I first started Nuxeo 5.5 EP with my oracle database configured with OWNER rights. Then I wanted to connect it with USER rights, USER has synonyms so USER does not have rights to CREATE table.

All the tables are there in database, but when I started the nuxeo server it gave me errors like the following:

2012-05-07 08:00:28,691 ERROR [org.hibernate.tool.hbm2ddl.SchemaUpdate] Unsuccessful: create table RECM_USER.NXP_LOGS (LOG_ID integer not null, LOG_EVENT_CATEGORY varchar2(255 char), LOG_EVENT_COMMENT varchar2(1024 char), LOG_DOC_LIFE_CYCLE varchar2(255 char), LOG_DOC_PATH varchar2(1024 char), LOG_DOC_TYPE varchar2(255 char), LOG_DOC_UUID varchar2(255 char), LOG_EVENT_DATE timestamp, LOG_EVENT_ID varchar2(255 char) not null, LOG_PRINCIPAL_NAME varchar2(255 char), LOG_REPO_ID varchar2(255 char), primary key (LOG_ID)) 2012-05-07 08:00:28,691 ERROR [org.hibernate.tool.hbm2ddl.SchemaUpdate] ORA-01031: insufficient privileges

I referred to this: http://doc.nuxeo.com/display/ADMINDOC/VCS+Configuration

and set the

but nuxeo server again tries to create tables; and the errors persists.

Where am I wrong..

0 votes

2 answers

1049 views

ANSWER



<noDDL> only controls VCS, but given the error message you show your problem comes from Hibernate.

In any case if you want a kind of “noDDL” for hibernate you still must create the tables by hand before starting Nuxeo, it needs them.

0 votes



Florent, all the table are setup in my oracle database, for the above error I mentioned, NXP_LOGS exists in my oracle database.
05/08/2012


How did you set noDDL to true: which file(s) did you change?
Did you precisely write <noDDL> and not <noddl> (in lowercase)?

Note with INFO level on “org.nuxeo.ecm.core.storage.sql.jdbc”, if no DDL was properly set, you would see a log line stating that JDBCBackend is “Skipping database creation”.

0 votes



Julien thanks for the reply,

Thats my default-repository-config.xml file in templates/oracle as I have specified template = oracle in nuxeo.conf file.

<code> <?xml version="1.0"?> <component name="default-repository-config"> <extension target="org.nuxeo.ecm.core.repository.RepositoryService"

point=&quot;repository&quot;&gt;
&lt;repository name=&quot;default&quot;
  factory=&quot;org.nuxeo.ecm.core.storage.sql.ra.PoolingRepositoryFactory&quot;&gt;
  &lt;repository name=&quot;default&quot;&gt;
    &lt;clustering enabled=&quot;${repository.clustering.enabled}&quot; delay=&quot;${repository.clustering.delay}&quot; /&gt;
    &lt;binaryStore path=&quot;${repository.binary.store}&quot; /&gt;
    &lt;binaryManager class=&quot;org.nuxeo.ecm.core.storage.sql.XORBinaryManager&quot; key=&quot;test&quot;/&gt;
    &lt;schema&gt;
      &lt;field type=&quot;largetext&quot;&gt;note&lt;/field&gt;
      &lt;field type=&quot;largetext&quot;&gt;relatedtext&lt;/field&gt;
      &lt;field type=&quot;largetext&quot;&gt;webp:content&lt;/field&gt;
      &lt;field type=&quot;largetext&quot;&gt;webc:welcomeText&lt;/field&gt;
      &lt;field type=&quot;largetext&quot;&gt;comment:comment&lt;/field&gt;
      &lt;field type=&quot;largetext&quot;&gt;post&lt;/field&gt;
      &lt;field type=&quot;largetext&quot;&gt;mail:mail&lt;/field&gt;
    &lt;/schema&gt;
    &lt;indexing&gt;
      &lt;fulltext&gt;
        &lt;index name=&quot;default&quot;&gt;
          &lt;!-- all props implied --&gt;
        &lt;/index&gt;
        &lt;index name=&quot;title&quot;&gt;
          &lt;field&gt;dc:title&lt;/field&gt;
        &lt;/index&gt;
        &lt;index name=&quot;description&quot;&gt;
          &lt;field&gt;dc:description&lt;/field&gt;
        &lt;/index&gt;
      &lt;/fulltext&gt;

    &lt;/indexing&gt;
    &lt;xa-datasource&gt;oracle.jdbc.xa.client.OracleXADataSource&lt;/xa-datasource&gt;
    &lt;property name=&quot;URL&quot;&gt;jdbc:oracle:thin:@${nuxeo.db.host}:${nuxeo.db.port}:${nuxeo.db.name}
    &lt;/property&gt;
    &lt;property name=&quot;User&quot;&gt;${nuxeo.db.user}&lt;/property&gt;
    &lt;property name=&quot;Password&quot;&gt;${nuxeo.db.password}&lt;/property&gt;
    &lt;noDDL&gt;true&lt;/noDDL&gt;
  &lt;/repository&gt;
&lt;/repository&gt;

</extension> </component> </code>

05/08/2012

Julien, the no DDL property is successfully set as Im able to see the following line in my logs:

2012-05-08 07:22:07,164 INFO [org.nuxeo.ecm.core.storage.sql.jdbc.JDBCBackend] Skipping database creation

05/08/2012