Server is shutting down right after starting

Hello,

I've successfully installed nuxeo on my computer but i can't get to start the server.

More exactly, it start for about a handfull of second then shut down on his own. I am able to load the very first page of the setup wizard before it shut down if i click at the right time, so the problem probably isn't coming from an incorrect installation. I've tried uninstalling and re-installing in a different location, starting the .bat as admin and disabling various process without any results.

Startup logs are showing no errors.

2012-04-24 12:08:49,763 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] Nuxeo home:          C:\Nuxeo 
2012-04-24 12:08:49,763 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] Nuxeo configuration: C:\ProgramData\Nuxeo\conf\nuxeo.conf
2012-04-24 12:08:49,763 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] Nuxeo home:          C:\Nuxeo
2012-04-24 12:08:49,763 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] Nuxeo configuration: C:\ProgramData\Nuxeo\conf\nuxeo.conf
2012-04-24 12:08:49,779 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] Include template: C:\Nuxeo\templates\common
2012-04-24 12:08:49,779 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] Include template: C:\Nuxeo\templates\default
2012-04-24 12:08:49,944 INFO  [org.nuxeo.launcher.config.ServerConfigurator] Detected Tomcat server.
2012-04-24 12:08:49,944 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] No current configuration, generating files...
2012-04-24 12:08:50,004 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator] Configuration files generated.
2012-04-24 12:08:51,247 WARN  [org.nuxeo.launcher.NuxeoLauncher] Server started with process ID 6932.
  • Error logs are empty.
  • Windows seven 32bits

Thanks.

0 votes

2 answers

1900 views

ANSWER



Since you're on Windows, you have installed/reinstalled, I would make absolutely sure that your nuxeoctl.bat is using the correct Nuxeo Home/Conf file. On Windows a registry entry is used by default for default configuration file location.

Try editing nuxeoctl.bat and add these two lines right after initial comments…

set NUXEO_HOME=C:\path\to\nuxeoinstall        (replace path\to\nuxeoinstall with your install dir)
set NUXEO_CONF=%NUXEO_HOME%\bin\nuxeo.conf

And then add just after the tag :FOUND_NUXEO_LAUNCHER add a line to jump around registry stuff

rem  avoid the registry
if not "%NUXEO_CONF%" == "" if exist "%NUXEO_CONF%" goto FOUND_NUXEO_CONF

This will at least ensure everything is pointed to the right place, and there aren't any artifacts from a previous install.

2 votes



Thanks for your answer.

My first install was in the default "program files" folder. After getting the problem and reading about the administrator right issue, I tried running the .bat as administrator then re-installing everything in C:\Nuxeon.

I just tried your solution, unfortunately I still get the same error. The server start for a few seconds then shut down. :|

04/24/2012

Do you have anything else running on any of the Nuxeo default ports?
04/24/2012

I have killed most of the process that I thought could mess up with Nuxeo (Without result yet) but I don't know how to be sure.

What are the default ports and how do i check their aviablility ?

04/24/2012

So it's working now.

I'll try to figure out what went right, write it down here and close the thread.

Thanks for your time.

04/24/2012

Good to hear you got it working
04/24/2012

I tried restarting all the process but Nuxeo is still working fine.

Maybe completing the wizard changed something ? I don't know, I think you were right and it was probably something messing up the port though.

Anyway, thanks, I'm marking this as resolved.

04/24/2012


hi,

I just spend 3 hours on a stupid mistake,with exactly the same result, nuxeo shutting down after 5min even every thing seem working.
Check your nuxeo.conf, I bind it to my eth0 interface and forgotten to change nuxeo.loopback.url (was still on localhost)
here my config, now everything work :

nuxeo.templates=postgresql,dam,collaboration
nuxeo.bind.address=10.3.36.220
nuxeo.server.http.port=8081
nuxeo.server.ajp.port=8010
nuxeo.server.https.port=8444
nuxeo.url=http://10.3.36.220:8081/nuxeo
nuxeo.loopback.url=http://10.3.36.220:8081/nuxeo
org.nuxeo.ecm.contextPath=/nuxeo

Hope this help.

0 votes