Nuxeo starts then stop immediatly

Hi, I have just installed nuxeo 5.6 (nuxeo-cap-5.6-tomcat) on linux, and set it up. When I start the program, everything is fine, but the process stops immediatly, with no error in the logs. I have activated the debug, but no additional error info.

You can find the startup log below, everything is fine up to process detection. But 1 or 2 seconds later, process does not exists anymore with no error at all.

Any idea of what is going on or how to get additional info?

I ma using OpenJDK (OpenJDK Runtime Environment (build 1.6.0-b09))

Here is the debug log:

[root@genoweb2 ~]# /etc/init.d/nuxeo start
Starting Nuxeo\n
Launcher command: /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/java -Dlauncher.java.opts=-Xms512m -Xmx1024m -XX:MaxPermSize=512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dfile.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Dnuxeo.home=/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat -Dnuxeo.conf=/etc/nuxeo/nuxeo.conf -Dnuxeo.log.dir=/var/log/nuxeo -jar /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/tmp/nuxeo-launcher-14242.jar --quiet --debug startbg
10:54:22,897 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.<init>(ConfigurationGenerator.java:341)] Nuxeo home:          /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat
10:54:22,902 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.<init>(ConfigurationGenerator.java:342)] Nuxeo configuration: /etc/nuxeo/nuxeo.conf
10:54:22,938 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.includeTemplates(ConfigurationGenerator.java:787)] Include template: /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/templates/common-base
10:54:22,943 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.includeTemplates(ConfigurationGenerator.java:787)] Include template: /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/templates/common
10:54:22,943 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.includeTemplates(ConfigurationGenerator.java:787)] Include template: /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/templates/default
10:54:22,949 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.getBindAddress(ConfigurationGenerator.java:1234)] Configured bind address: /192.168.1.241
10:54:22,950 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.evalLoopbackURL(ConfigurationGenerator.java:630)] Set as loop back URL: http://192.168.1.241:8383/nuxeo
10:54:22,950 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.setBasicConfiguration(ConfigurationGenerator.java:524)] Nuxeo Dev mode is not enabled
10:54:22,953 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.setBasicConfiguration(ConfigurationGenerator.java:541)] Nuxeo Seam HotReload is not enabled
10:54:22,969 DEBUG [org.nuxeo.launcher.NuxeoLauncher.extractCommandAndParams(NuxeoLauncher.java:1539)] Launcher command: startbg
10:54:22,969 DEBUG [org.nuxeo.launcher.NuxeoLauncher.setArgs(NuxeoLauncher.java:1524)] GUI: option not set - platform is not Windows -> do not start GUI
10:54:23,018 DEBUG [org.nuxeo.launcher.NuxeoLauncher.getPid(NuxeoLauncher.java:1394)] regexp: ^(?!/bin/sh).*\Q/etc/nuxeo/nuxeo.conf\E.*\Qorg.apache.catalina.startup.Bootstrap\E.*$ pid:null
10:54:23,020 INFO  [org.nuxeo.launcher.config.TomcatConfigurator.isConfigured(TomcatConfigurator.java:67)] Detected Tomcat server.
10:54:23,028 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator.run(ConfigurationGenerator.java:390)] Configuration files generation (nuxeo.force.generation=true)...
10:54:23,055 DEBUG [org.nuxeo.launcher.config.ServerConfigurator.deleteTemplateFiles(ServerConfigurator.java:184)] Remove lib/h2-1.1.114-nx.jar
10:54:23,060 DEBUG [org.nuxeo.launcher.config.ServerConfigurator.deleteTemplateFiles(ServerConfigurator.java:184)] Remove lib/derby-10.5.3.0_1.jar
......
10:54:23,206 DEBUG [org.nuxeo.launcher.config.ServerConfigurator.deleteTemplateFiles(ServerConfigurator.java:184)] Remove conf/Catalina/localhost/nuxeo.xml
10:54:23,208 DEBUG [org.nuxeo.launcher.config.ServerConfigurator.deleteTemplateFiles(ServerConfigurator.java:184)] Remove nxserver/config/default-repository-config.xml
10:54:23,209 DEBUG [org.nuxeo.launcher.config.ServerConfigurator.deleteTemplateFiles(ServerConfigurator.java:184)] Remove nxserver/config/webengine.properties
10:54:24,283 DEBUG [org.nuxeo.launcher.commons.text.TextTemplate.processDirectory(TextTemplate.java:350)] Backup /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/./webapps/ROOT/WEB-INF/web.xml
10:54:24,302 DEBUG [org.nuxeo.launcher.commons.text.TextTemplate.processDirectory(TextTemplate.java:350)] Backup /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/./webapps/ROOT/index.html
10:54:24,406 DEBUG [org.nuxeo.launcher.commons.text.TextTemplate.processDirectory(TextTemplate.java:350)] Backup /web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/conf/server.xml
10:54:24,636 INFO  [org.nuxeo.launcher.config.ConfigurationGenerator.generateFiles(ConfigurationGenerator.java:716)] Configuration files generated.
10:54:24,639 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.getBindAddress(ConfigurationGenerator.java:1234)] Configured bind address: /192.168.1.241
10:54:24,639 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.checkAddressReachable(ConfigurationGenerator.java:1249)] Checking availability of /192.168.1.241
10:54:24,640 DEBUG [org.nuxeo.launcher.config.ConfigurationGenerator.checkPortAvailable(ConfigurationGenerator.java:1273)] Checking availability of port 8383 on address /192.168.1.241
10:54:25,290 DEBUG [org.nuxeo.launcher.NuxeoLauncher.doStart(NuxeoLauncher.java:1128)] Check if install in progress...
10:54:25,292 DEBUG [org.nuxeo.launcher.NuxeoLauncher.start(NuxeoLauncher.java:405)] Server command: [/bin/sh, -c,  /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java -Xms512m -Xmx1024m -XX:MaxPermSize=512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dfile.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -cp .:/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/nxserver/lib:/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/bin/bootstrap.jar -Dnuxeo.home=/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat -Dnuxeo.conf=/etc/nuxeo/nuxeo.conf -Dnuxeo.log.dir=/var/log/nuxeo -Dnuxeo.data.dir=/web/genoweb2/nuxeo/data -Dnuxeo.tmp.dir=/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/tmp -Djava.io.tmpdir=/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/tmp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Dcatalina.base=/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat -Dcatalina.home=/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat -Djava.endorsed.dirs=/web/genoweb2/nuxeo/nuxeo-cap-5.6-tomcat/endorsed org.apache.catalina.startup.Bootstrap start]
10:54:26,329 DEBUG [org.nuxeo.launcher.NuxeoLauncher.getPid(NuxeoLauncher.java:1394)] regexp: ^(?!/bin/sh).*\Q/etc/nuxeo/nuxeo.conf\E.*\Qorg.apache.catalina.startup.Bootstrap\E.*$ pid:1771
10:54:26,331 WARN  [org.nuxeo.launcher.NuxeoLauncher.start(NuxeoLauncher.java:410)] Server started with process ID 1771.
0 votes

1 answers

1133 views

ANSWER



Found the issue. I changed tomcat port, but it was also necessary to change those ports: nuxeo.server.ajp.port=xxxx nuxeo.server.tomcat_admin.port=xxx

conflicting with an existing tomcat.

This issue does not appear in logs but it appears on console when existing directly the java command line.

0 votes