Server can't start.

Hello people,

I am having a lot of trouble getting Nuxeo to actually work. I'm sure that if I can get it to start it will be the ideal solution to my companies needs but that is a big if…

I installed the windows version and the setup completed successfully.

When I try to run the Nuxeo application I get this error message in the logs and the programme just grinds to a halt:

2011-11-30 14:36:03,537 ERROR [org.nuxeo.launcher.NuxeoLauncher] Could not run configuration org.nuxeo.launcher.config.ConfigurationException: Nuxeo requires Java 1.6 (detected 1.7.0_01).

at org.nuxeo.launcher.config.ConfigurationGenerator.verifyInstallation(ConfigurationGenerator.java:749)
at org.nuxeo.launcher.NuxeoLauncher.configure(NuxeoLauncher.java:856)
at org.nuxeo.launcher.NuxeoLauncher.doStart(NuxeoLauncher.java:596)
at org.nuxeo.launcher.NuxeoLauncher.doStartAndWait(NuxeoLauncher.java:478)
at org.nuxeo.launcher.NuxeoLauncher.doStartAndWait(NuxeoLauncher.java:447)
at org.nuxeo.launcher.gui.NuxeoLauncherGUI$3.run(NuxeoLauncherGUI.java:182)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I really want to get this working but I have no idea what this message even means. I would really appreciate any help or any light that anyone can shed onto this.

Thanks in advance.

0 votes

1 answers

2205 views

ANSWER



It appears you have Java 1.7 installed and Nuxeo needs Java 1.6.

See second line of log file.

Karl

1 votes



Ah I thought that might be backwards compatible, I will change the version to java 1.6, thanks for the quick responce.
11/30/2011