creating nuxeo-web-ui

Hi all,

I tried to create the Web UI marketplace ZIP as described in https://github.com/nuxeo/nuxeo-web-ui/. Beside some minor issues regarding version conflicts during “npm install” (which I hoped to have solved by modifying the packages.json) I run in a major issue. During “mvn clean install” Maven tried to find the parent artifact “nuxeo-parent” which seems to be in in https://packages.nuxeo.com/repository/maven-internal/ which I coulld not access as a non privileged user. The build process stopped with the following message:

Downloading from maven-internal: https://packages.nuxeo.com/repository/maven-internal/org/nuxeo/nuxeo-parent/2021.9/nuxeo-parent-2021.9.pom
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[FATAL] Non-resolvable parent POM for org.nuxeo.web.ui:nuxeo-web-ui-parent:3.0.8-SNAPSHOT: Could not transfer artifact org.nuxeo:nuxeo-parent:pom:2021.9 from/to maven-internal (https://packages.nuxeo.com/repository/maven-internal/): authentication failed for https://packages.nuxeo.com/repository/maven-internal/org/nuxeo/nuxeo-parent/2021.9/nuxeo-parent-2021.9.pom, status: 401 Unauthorized and 'parent.relativePath' points at wrong local POM @ line 3, column 11

In contrast to the current version above, it is possible to create the old version 10.10.

Has Nuxeo switched to closed source? How can I access the needed resources?

Thanks, Elmar

0 votes

1 answers

116 views

ANSWER



Guessing here, but did you try checking out the whole nuxeo repository (https://github.com/nuxeo/nuxeo) + using clone.py to checkout the addons (including nuxeo-web-ui). and then compile only the web-ui in addons/nuxeo-web-ui?

Can you tell me what you did to fix the npm install problem? I am stuck at primordials is not defined

 [exec] > nuxeo-web-ui@2.4.53 lint
 [exec] > gulp lint && polymer lint -i elements/*/*.html
 [exec] 
 [exec] fs.js:45
 [exec] } = primordials;
 [exec]     ^
 [exec] 
 [exec] ReferenceError: primordials is not defined
0 votes



Hi Konrad,

thanks for the hint regarding installing the parent subproject to my local repository. That was the solution to my problem.

Regarding your primoridals problem: Please use node version v14.18.1 (Node Version Manager nvm is your friend). With that version, it works best. And in addition I do not have to change anything in "packages.json" to resolve version problems of node packages, which I wrote above in my initial post.

Good luck Elmar

11/15/2021

Thanks Elmar. I'll try switching the node version

Best, Konrad

11/17/2021