How to troubleshoot nuxeo bulk computation error

Hello,

I want to share my problem with you and hope someone can help me.

I ran a csvExport on about 800 documents, it took a little while to complete but eventually I got my csv file.

Except that the next time you start nuxeo, I got the following error message in the console:

ERROR [AbstractBulkComputation] Stopping processing, unknown command: 15a75e2b-11da-4f08-9e89-83b1f3890bfe, offset: csvExport-00:+80182744449038, record: Record{watermark=212138546712018944, wmDate=2021-04-15 13:11:08.152, flags=[DEFAULT], key='15a75e2b-11da-4f08-9e89-83b1f3890bfe:1', data.length=3750, data="....%'..Y.H15a75e2b-11da-4f08-9e89-83b1f3890bfe..H72ab6c70-e376-4b98-b4c6-741bab43bda9H56d72278-c00c-477f-a911-0a13e4c9ae69H12e"}.

I tried to investigate the problem that's why I launched the following command:

./bin/stream.sh tail --chronicle ./nxserver/data/stream/bulk -l done --codec avro -n 20 | grep +80182744449038

I got the following answer :

|done-00:+80182744449038|2021-02-11 14:32:37.924:0|[DEFAULT]|be4043e1-5fcf-44df-be68-a0cabec1995f|171|{"commandId": "be4043e1-5fcf-44df-be68-a0cabec1995f", "action": "csvExport", "username": "Administrator", "delta": false, "errorCount": 0, "errorMessage": null, "processed": 32, "state": "COMPLETED", "submitTime": 1613050357319, "scrollStartTime": 1613050357385, "scrollEndTime": 1613050357401, "processingStartTime": null, "processingEndTime": null, "completedTime": 1613050357895, "total": 32, "processingDurationMillis": null, "result": "{\"url\":\"nxbigblob/be4043e1-5fcf-44df-be68-a0cabec1995f\"}"}|

And by running the following command to see the status of the command:

curl -s -X GET "http://localhost:8080/nuxeo/api/v1/bulk/be4043e1-5fcf-44df-be68-a0cabec1995f"  -u Administrator:Administrator  -H 'content-type: application/json' | jq .

I got the following response:

{
  "entity-type": "exception",
  "status": 404,
  "message": "Bulk command with id=be4043e1-5fcf-44df-be68-a0cabec1995f doesn't exist"
}

Do you have any idea how I can fix this?

Thank you

0 votes

0 answers

65 views

ANSWER

Note that the error disappeared after deleting the nxserver/data/stream/bulk/csvExport folder but I don't think this is the right solution to fix the problem.
04/27/2021