Issue with XORBinaryManager in Nuxeo 5.6-RC2

I configured Nuxeo 5.5 to use XOR encryption by specifying BinaryManager to use the following class:
class=“org.nuxeo.ecm.core.storage.sql.XORBinaryManager” in default-repository-config.xml
And the encryption and decryption worked perfectly fine.

In Nuxeo 5.6-RC2, I tried to use XOR encryption by adding : nuxeo.core.binarymanager=org.nuxeo.ecm.core.storage.sql.XORBinaryManager in nuxeo.conf

Logs show :
2012-08-15 12:22:31,479 INFO [org.nuxeo.ecm.core.storage.sql.DefaultBinaryManager] Repository 'default' using XORBinaryManager and binary store: D:\recm\data\binaries

Now one thing is for sure, Nuxeo 5.6-RC2 is using XORBinaryManager for encryption but it does not encrypt the files as we are able to open and view the uploaded files from file system but when we try to download the files via Nuxeo 5.6-RC2 DM it says the file is corrupted or damaged.

What we have concluded from that is Nuxeo 5.6-RC2's XORBinaryManager is not encrypting the files correctly but when downloading, it tries to decrypt the file and unnecessarily unscramble the bytes and the file gets damaged.

We think its a Nuxeo 5.5-RC2 bug.

Yet, there is no Nuxeo 5.6-RC2 documentation available so could anyone confirm are we configuring Nuxeo BinaryManager correctly, or its a bug?

0 votes

1 answers

1250 views

ANSWER

This is the proper way to use it. There must be another factor in play…
08/21/2012

What factor? If we are configuring it correctly and its not working, then its Nuxeo 5.6-RC2 bug. Right?
08/21/2012

Probably. We'll check.
08/23/2012



See https://jira.nuxeo.com/browse/NXP-9885
This should be fixed in the next build.

0 votes



Thanks Guillaume. We are looking forward to it.
08/23/2012