Disable auto versioning

Hello,

In Nuxeo 5.6, I had successfully enabled auto versioning with the following parameter in nuxeo.conf :

org.nuxeo.ecm.platform.liveedit.autoversioning=minor

Then I upgraded Nuxeo to 6.0-HF05 and the auto versioning is still OK. But now, i had to disable the auto versioning and I can't do it with :

org.nuxeo.ecm.platform.liveedit.autoversioning=none.

I also tried VersioningService XP as described here. But this still don't work.

How can I disable auto versioning in Nuxeo 6.0-HF05 ?

Thanks.

0 votes

1 answers

1394 views

ANSWER

Hi,

Do you want to disable the autoversioning just for live edit or globally? How did you configure the versioning policy for your documents?

07/28/2015

Hello, I want to disable autoversioning globally. I didn't modify versioning policy yet. Thanks you.
07/29/2015

If you did not modify the versioning policy, there should not be auto versioning in your instance, that's the default behavior. So we need to know how you set the autoversioning to help you disable it.
07/29/2015

Well, I don't use "VersioningRule" in my bundles and I just modified "liveedit.autoversioning" parameter in nuxeo.conf. Is there some special XP for "versioning policy" as you said ? But I forgot to mention that I edit document via WebDAV. Maybe this is the point ?
07/30/2015

Hello, I reinstalled Nuxeo 6.0 following Nuxeo tutorial installation with no customs bundles. I noticed that the first save of a document from WebDAV access don't create a version document. But the followings save will do : I ended up with 0.n+ versions of the document.

Is here a way to prevent that ? Or is it a bug ? Thanks.

09/02/2015



HI, I would suggest you to use versioning rules so that you can disable/enable the versioning for selective documents.

Write an extension for the same to happen.

<extension target="org.nuxeo.ecm.core.versioning.VersioningService"
        point="versioningRules">
        <versioningRule typeName="Folder">
            <initialState major="0" minor="0" />
            <options lifeCycleState="*">
                <none default="true" />
                <minor />
                <major />
            </options>
        </versioningRule>
        <versioningRule typeName="Domain">
            <initialState major="0" minor="0" />
            <options lifeCycleState="*">
                <none default="true" />
                <minor />
                <major />
            </options>
        </versioningRule>
        <versioningRule typeName="File">
            <initialState major="0" minor="0" />
            <options lifeCycleState="*">
                <none default="true" />
                <minor />
                <major />
            </options>
        </versioningRule>
        <versioningRule typeName="Workspace">
            <initialState major="0" minor="0" />
            <options lifeCycleState="*">
                <none default="true" />
                <minor />
                <major />
            </options>
        </versioningRule>

        <versioningRule typeName="YourDocument">
            <initialState major="0" minor="0" />
            <options lifeCycleState="*">
                <none default="true" />
                <minor />
                <major />
            </options>
        </versioningRule>
    </extension>

Hope this helps. :)

0 votes