Schema definition override doesn't work.

I want to override the group schema definition with my own attribute with the Nuxeo default one.

I create with Nuxeo IDE a “Nuxeo plugin Project”.

I add this component xml file into my eclipse project into the src/main/resources/OSGI-INF/myproject-schema-contrib.xml file:

<component name="fr.mycompanyname.myproject.schema.contribution">
  <!-- to be sure to deployed after the Nuxeo default contributions>
  <require>org.nuxeo.ecm.directory.types</require>

  <extension target="org.nuxeo.ecm.core.schema.TypeService" point="schema">
    <schema name="group" src="directoryschema/group.xsd"/>
  </extension>
</component>

I add my specific group.xsd definition into src/main/resources/directoryschema/ directory into my eclipse project. I add this following line into the src/main/resources/META-INF/MANIFEST.MF file:

Nuxeo-Component: OSGI-INF/myproject-schema-contrib.xml

The schema group deployed is always the default one.

0 votes

1 answers

2937 views

ANSWER



Dear Me,

As explained here, you must add the override=“true” parameter into your schema description.

<schema override="true" name="group" src="directoryschema/group.xsd"/>

You must have a message in your log that says your contribution is skipped as you didn't put this attribute I'm not sure but I think…

Regards

1 votes