Nuxeo 5.5: How can I apply structural changes to the default galaxy theme layout?

Hi,

I want to re-arrange, remove some cells from the default galaxy theme layout.
What I've tried so far:

  1. I've created a customization project in an Eclipse Nuxeo-IDE environment.
  2. I've copied the themes folder from nuxeo-platform-webapp-core into the project's resources.
  3. I've created a theme-contrib.xml in OSGI-INF with a theme extension point referring my project's themes/document-management.xml (s.b.)
  4. I've kept the original theme name galaxy in document-management.xml (actually I haven't changed anything in my document-management.xml).
  5. Until now I haven't created a project jar-file, instead I've used the hot-deploy mechanism of the Nuxeo-IDE debug environment to apply 'structural' changes to the default theme.

After hot-deploy Nuxeo-DM appeared without styling AND without applying my document-management.xml (indeed Nuxeo continued to use the theme from nuxeo-webengine-site?) and I've gotten following warnings/errors:

[..]
2012-05-15 10:18:51,680 DEBUG [org.nuxeo.runtime.osgi.OSGiRuntimeService] Bundle: nuxeo-customization components: OSGI-INF/theme-contrib.xml
2012-05-15 10:18:51,680 DEBUG [org.nuxeo.runtime.osgi.OSGiRuntimeService] Loading component for: nuxeo-customization path: OSGI-INF/theme-contrib.xml url: file:/D:/workspace_nuxeo/nuxeo-customization/bin/main/OSGI-INF/theme-contrib.xml
2012-05-15 10:19:18,797 WARN [org.nuxeo.theme.html.ui.ThemeStyles] Could not resolve theme descriptor for name 'galaxy'
2012-05-15 10:19:20,427 ERROR [org.nuxeo.ecm.platform.web.common.exceptionhandling.DefaultNuxeoExceptionHandler] javax.servlet.ServletException: java.io.IOException: Theme not found: galaxy

at org.nuxeo.ecm.platform.ui.web.rest.FancyURLFilter.doFilter(FancyURLFilter.java:137)  

[..]

Any help would be appreciated Thanks

My theme-contrib.xml:
<?xml version=“1.0”?>
<component name=“org.mycompany.theme.nuxeo.default”>
<require>org.nuxeo.theme.nuxeo.default</require>
<extension target=“org.nuxeo.theme.services.ThemeService” point=“themes”>

&lt;theme>&lt;src&gt;themes/document-management.xml&lt;/src&gt;&lt;/theme&gt;  

</extension>
</component>

0 votes

5 answers

1973 views

ANSWER

hi have the same problem… have you tested the bundle and found the problem? Thank you
05/18/2012



Hi,

this seems to be a problem with the hot-deploy mechanism in the Nuxeo-IDE. After creating a marketplace bundle link text and installing it at my local nuxeo instance, structural changes to the galaxy theme layout have been applied.

Regards.

0 votes



Hello, I have a similar issue, but I am not using the hot deploy feature in Nuxeo IDE. I am doing a maven install and replacing the jar file into the nuxeo/nxserver/plugins directory and then running a ./nuxeoctl console from the terminal.
I made some structural changes, for instance I deleted the footer, but when I deploy the change, the structure remains unchanged.

Here are the changes I made to the following files

META-INF/MANIFEST.MF
Manifest-Version: 1.0
Bundle-ManifestVersion: 1
Bundle-Name: cookbook-basic-bundle
Bundle-SymbolicName: org.nuxeo.cookbook.basic;singleton:=true
Bundle-Version: 0.0.1
Bundle-Vendor: Nuxeo
Nuxeo-Component: OSGI-INF/theme-contrib.xml

OSGI-INF/theme-contrib.xml

 <theme> <br>
   <src>themes/document-management.xml</src> <br>
  </theme> <br>
</extension> <br>



themes/document-management.xml
the only change I made here was removed the following lines



0 votes



Check your typo in OSGI-INF/theme-contib.xml line:1 first.
07/02/2012

Edgar, my apologies, that was my typo here, not on the actual OSGI/theme-contrib.xml document
07/02/2012

You've referred to themes/document-management.xml in your theme-contrib.xml but you've applied changes to a themes/deployment-fragment.xml.
07/02/2012

Do you really move the jar-file to the plugin subdir? Try the tomcat:nuxeo/nxserver/bundles directory instead.
07/02/2012

yes i do.
when i move jar file to nuxeo/nxserver/plugins directory the layout structure remains unchanged but the new logo does display. tried your advice, moved jar file to the nuxeo/nxserver/bundles directory … original nuxeo logo and layout structure remain
07/02/2012

According to your manifest file I guess you've derived your project from this documentation. The plugin directory doesn't work for me (same results as in your case). Note, that I am working with a 5.6-SNAPSHOT and that the theme handling is currently a subject in change. Try to isolate the extension point 'themes'. Tweak the "lib/log4j.xml" for your needs (i.e.: org.nuxeo.runtime.osgi.OSGiRuntimeService <= DEBUG, etc…) and consult the server.log.
07/03/2012


i have created a jira issue: https://jira.nuxeo.com/browse/NXIDE-170

i will test the workaround. thank you

0 votes



how can i open a bug about this nuxeo-ide hot-deploy issue? My customization are simple and don't require a marketplace bundle.

Thank you

0 votes



You can fill a bug report for the IDE at following place https://jira.nuxeo.com/browse/NXIDE

Thanks

05/22/2012

As a workaround you can (1) create a simple marketplace bundle (s.a) for the structural changes, (2) install it at your nuxeo instance and (3) create a new project and (4) use the IDE to hot-deploy styles and favors (s.a). This way you shouldn't be forced to recurrently create a new marketplace bundle.
05/22/2012


Hello,

I can't see anything bad in your description, but i'm not an expert on Nuxeo IDE, it is still a young tool.

Is it possible to upload your .jar in the following link ?

http://demo.nuxeo.com/nuxeo/nxdoc/default/fdfb4623-503f-4701-9fbc-65533cb772f5/view_documents?tabIds=%3A&conversationId=0NXMAIN

It will be easier for us to test it and check directly what is wrong without wasting your time.

Thanks

0 votes



Hmmmh..? Account needed!
05/15/2012

You can use the default account 'Administrator:Administrator'
05/15/2012

Yes, i forgot to mention it, it is the default user account. My bad, sorry for that.
05/15/2012

Thanks, upload done.
05/15/2012