Problem after upgrading from 5.8 to 6

Hi,

I tried to upgrade my home nuxeo server yesterday and met some problem. As I upgraded the Ubuntu distribution to, I first met problem with the upgrade of prosgresql. That was a dependency problem and found a solution on Ubuntu forums.

Now my Ubuntu and postgresql seems to be clean, but Nuxeo still don't want to start. The problem seems to be due to the re-installation of packages installed on the 5.8 version of nuxeo :

Paramétrage de nuxeo (6.0-01) ...
 * Trying to re-install previously installed packages
Detected Tomcat server.
Nuxeo home:          /var/lib/nuxeo/server
Nuxeo configuration: /etc/nuxeo/nuxeo.conf
Include template: /var/lib/nuxeo/server/templates/common-base
Include template: /var/lib/nuxeo/server/templates/common
Include template: /var/lib/nuxeo/server/templates/postgresql
Unable to fetch remote packages list
Unable to fetch remote packages list
Unable to fetch remote packages list
Unable to install pacakge: nuxeo-agenda
Unable to install pacakge: nuxeo-dm
Unable to install pacakge: nuxeo-flavors-unicolor
Unable to install pacakge: nuxeo-sites-blogs
Unable to install pacakge: nuxeo-togetherjs-marketplace

Dependency resolution:
  Installation order (2):        nuxeo-dam-6.0.0/nuxeo-diff-1.5.0
  Local packages to install (2): nuxeo-diff:1.5.0, nuxeo-dam:6.0.0

Installing nuxeo-dam-6.0.0
Installing nuxeo-diff-1.5.0
 * Starting Nuxeo
                                                                                Moving /mnt/nuxeo/data/packages content to /var/lib/nuxeo/server/packages...
Could not run configuration: NXP-8014 move failed: Destination '/var/lib/nuxeo/server/packages/store' already exists
                                                                         [fail]
invoke-rc.d: initscript nuxeo, action "start" failed.
dpkg: error processing package nuxeo (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 6
Des erreurs ont été rencontrées pendant l'exécution :
 nuxeo
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried few things to solve the problem, like delete the /var/lib/nuxeo/server/packages/store directory, delete all files in /mnt/nuxeo/data/packages/store or delete the text in /mnt/nuxeo/data/installAfterRestart.log, but the result is always the same.

If anyone could give me a solution to restart my Nuxeo server and retrieve my documents, I would be very grateful.

Thanks in advance. Yann

0 votes

6 answers

2930 views

ANSWER



It looks like you're running into a conflict between the deb package upgrade and the launcher regarding the change of location of the marketplace packages cache.

Try the following (basically, to perform an upgrade without packages then install them afterwards):

/etc/init.d/nuxeo stop
su nuxeo -c "NUXEO_CONF=/etc/nuxeo/nuxeo.conf /var/lib/nuxeo/server/bin/nuxeoctl mp-purge"
rm -rf /var/lib/nuxeo/server/packages
rm -rf /mnt/nuxeo/data/packages
dpkg --configure -a     # (or apt-get upgrade)
/etc/init.d/nuxeo stop
su nuxeo -c "NUXEO_CONF=/etc/nuxeo/nuxeo.conf /var/lib/nuxeo/server/bin/nuxeoctl mp-init"
su nuxeo -c "NUXEO_CONF=/etc/nuxeo/nuxeo.conf /var/lib/nuxeo/server/bin/nuxeoctl mp-install nuxeo-dm nuxeo-dam"     # (adapt with your package list)
/etc/init.d/nuxeo/start
1 votes



Hi,

A long time since my last message… A friend came to help me and there was several problems around the DB.

First, after upgrading PostgreSQL from version 9.1 to 9.3, the port it listen to has changed. We edited the config file in order fix that.

Second, the database was still in the 9.1 folder, but it wasn't seen by 9.3. We installed the 9.1 version of PostgreSQL in a docker in order to dump the database and reimport it in the 9.3.

My Nuxeo server is now fixed and work well.

Thanks for your help. Yann

0 votes



Hi,

I had a look to my nuxeo.conf file on this week-end. Database fields are uncommented on both files (in /etc/nuxeo and in /mnt/nuxeo/config), but the two files are not identical. The one in /etc/nuxeo seems to be longer and some of it's fields are commented whereas they are not in /mnt/nuxeo/config.

When asked, on upgrading, I answered to keep my config file. Could the problem come from that?

BR

Yann

0 votes



The package expects the config file in /etc/nuxeo, you shouldn't move it from there.
If you want all of your install in /mnt/nuxeo, you should probably use the zip installation instead of the debian pacakge.
05/15/2015


psql doesn't work too :

root@Nuxeo:/home/nuxeo# psql
psql: could not connect to server: Aucun fichier ou dossier de ce type
        Is the server running locally and accepting
        connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?

/var/run/postgresql/.s.PGSQL.5432 seems to be empty.

Thanks again for your help.

0 votes



There is progress! With removing the /etc/nuxeo/pkglist.cache file, there is no longer dependency problem on step 5 :

apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Paramétrage de nuxeo (6.0-01) ...
 * Starting Nuxeo
                                                                                                                                                                                                                                                                                                                               Connexion refusée. Vérifiez que le nom de machine et le port sont corrects et que postmaster accepte les connexions TCP/IP.
Could not run configuration: Failed to connect on database: Connexion refusée. Vérifiez que le nom de machine et le port sont corrects et que postmaster accepte les connexions TCP/IP.
                                                                                                                                                                                                                                                                                                                        [fail]
invoke-rc.d: initscript nuxeo, action "start" failed.
dpkg: error processing package nuxeo (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 6
Des erreurs ont été rencontrées pendant l'exécution :
 nuxeo

Remains the problem of the database connection. I first checked that it has been upgraded :

apt-cache policy postgresql
postgresql:
  Installé : 9.3+154ubuntu1
  Candidat : 9.3+154ubuntu1
 Table de version :
 *** 9.3+154ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     9.3+154 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Then I tried, as root, to use command line to connect to the database. My goal was to check that the nuxeo table is still there. Ubuntu answer that the program is not installed and invite me to install postgres-xc :

root@Nuxeo:~# postgres
Le programme « postgres » n'est pas encore installé. Vous pouvez l'installer en tapant :
apt-get install postgres-xc

So, I tried to install postgres-xc, but Ubuntu answered that it can't due to dependency problem…

root@Nuxeo:~# apt-get install postgres-xc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 postgres-xc : Dépend: postgres-xc-client mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

My fear is that the table has been lost on upgrading. Is it a risk? If so, is it possible to retrieve the raw documents (without metadata)?

BR Yann

0 votes



There is very little chance that your database would have been lost, almost nothing deletes database data.
The client command-line for PostgreSQL is "psql", not "postgres". Check all your "nuxeo.db.*" parameters in your nuxeo.conf (commented or not) to figure out the correct ones and fix your configuration.
05/06/2015


Hi,

Thanks for your answer.

It's ok for the first line, the server is not running :

/etc/init.d/nuxeo stop
 * Stopping Nuxeo

Server is not running.
                                                                         [ OK ]

Ok for the second line too :

su nuxeo -c "NUXEO_CONF=/etc/nuxeo/nuxeo.conf /var/lib/nuxeo/server/bin/nuxeoctl mp-purge"
Detected Tomcat server.
Nuxeo home:          /var/lib/nuxeo/server
Nuxeo configuration: /etc/nuxeo/nuxeo.conf
Include template: /var/lib/nuxeo/server/templates/common-base
Include template: /var/lib/nuxeo/server/templates/common
Include template: /var/lib/nuxeo/server/templates/postgresql
Removed nuxeo-drive-1.4.0
Removed nuxeo-web-mobile-1.6.0
Removed nuxeo-template-rendering-6.4.0
Unable to fetch remote packages list
Unable to fetch remote packages list
Unable to fetch remote packages list

Dependency resolution:
  Uninstallation order (2):      nuxeo-diff-1.5.0/nuxeo-dam-6.0.0
  Local packages to remove (2):  nuxeo-diff:1.5.0, nuxeo-dam:6.0.0

Do you want to continue (yes/no)? [yes] yes
Uninstalling nuxeo-diff-1.5.0
Uninstalling nuxeo-dam-6.0.0
Removed nuxeo-dam-6.0.0
Removed nuxeo-diff-1.5.0

Ok for lines 3 and 4. Seems that I meet the same promblem with line 5 :

sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  linux-generic linux-headers-generic linux-image-generic
Les paquets suivants seront mis à jour :
  linux-generic-lts-quantal linux-headers-generic-lts-quantal
  linux-image-generic-lts-quantal linux-libc-dev
4 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 779 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-generic-lts-quantal amd64 3.13.0.52.59 [1 788 B]
Réception de : 2 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-headers-generic-lts-quantal amd64 3.13.0.52.59 [2 370 B]
Réception de : 3 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-image-generic-lts-quantal amd64 3.13.0.52.59 [1 786 B]
Réception de : 4 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-libc-dev amd64 3.13.0-52.85 [773 kB]
779 ko réceptionnés en 1s (555 ko/s)    
(Lecture de la base de données... 413468 fichiers et répertoires déjà installés.)
Préparation du décompactage de .../linux-generic-lts-quantal_3.13.0.52.59_amd64.deb ...
Décompactage de linux-generic-lts-quantal (3.13.0.52.59) sur (3.13.0.51.58) ...
Préparation du décompactage de .../linux-headers-generic-lts-quantal_3.13.0.52.59_amd64.deb ...
Décompactage de linux-headers-generic-lts-quantal (3.13.0.52.59) sur (3.13.0.51.58) ...
Préparation du décompactage de .../linux-image-generic-lts-quantal_3.13.0.52.59_amd64.deb ...
Décompactage de linux-image-generic-lts-quantal (3.13.0.52.59) sur (3.13.0.51.58) ...
Préparation du décompactage de .../linux-libc-dev_3.13.0-52.85_amd64.deb ...
Décompactage de linux-libc-dev:amd64 (3.13.0-52.85) sur (3.13.0-51.84) ...
Paramétrage de nuxeo (6.0-01) ...
 * Trying to reinstall previously installed packages
Detected Tomcat server.
Nuxeo home:          /var/lib/nuxeo/server
Nuxeo configuration: /etc/nuxeo/nuxeo.conf
Include template: /var/lib/nuxeo/server/templates/common-base
Include template: /var/lib/nuxeo/server/templates/common
Include template: /var/lib/nuxeo/server/templates/postgresql
Unable to fetch remote packages list
Unable to fetch remote packages list
Unable to fetch remote packages list
Unable to install pacakge: nuxeo-agenda
Unable to install pacakge: nuxeo-dm
Unable to install pacakge: nuxeo-flavors-unicolor
Unable to install pacakge: nuxeo-sites-blogs
Unable to install pacakge: nuxeo-togetherjs-marketplace

Dependency resolution:
  Installation order (2):        nuxeo-dam-6.0.0/nuxeo-diff-1.5.0
  Local packages to install (2): nuxeo-diff:1.5.0, nuxeo-dam:6.0.0

Installing nuxeo-dam-6.0.0
Installing nuxeo-diff-1.5.0
 * Starting Nuxeo
                                                                                                                                                                                                                    Connexion refusée. Vérifiez que le nom de machine et le port sont corrects et que postmaster accepte les connexions TCP/IP.
Could not run configuration: Failed to connect on database: Connexion refusée. Vérifiez que le nom de machine et le port sont corrects et que postmaster accepte les connexions TCP/IP.
                                                                                                                                                                                                             [fail]
invoke-rc.d: initscript nuxeo, action "start" failed.
dpkg: error processing package nuxeo (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 6
Paramétrage de linux-generic-lts-quantal (3.13.0.52.59) ...
Paramétrage de linux-headers-generic-lts-quantal (3.13.0.52.59) ...
Paramétrage de linux-image-generic-lts-quantal (3.13.0.52.59) ...
Paramétrage de linux-libc-dev:amd64 (3.13.0-52.85) ...
Des erreurs ont été rencontrées pendant l'exécution :
 nuxeo
E: Sub-process /usr/bin/dpkg returned an error code (1)

Line 6 give me the same as line 1. Line 7 seems to be ok :

su nuxeo -c "NUXEO_CONF=/etc/nuxeo/nuxeo.conf /var/lib/nuxeo/server/bin/nuxeoctl mp-init"
Detected Tomcat server.
Nuxeo home:          /var/lib/nuxeo/server
Nuxeo configuration: /etc/nuxeo/nuxeo.conf
Include template: /var/lib/nuxeo/server/templates/common-base
Include template: /var/lib/nuxeo/server/templates/common
Include template: /var/lib/nuxeo/server/templates/postgresql

Line 7 fail to install nuxeo-dm :

su nuxeo -c "NUXEO_CONF=/etc/nuxeo/nuxeo.conf /var/lib/nuxeo/server/bin/nuxeoctl mp-install nuxeo-dm nuxeo-dam"
Detected Tomcat server.
Nuxeo home:          /var/lib/nuxeo/server
Nuxeo configuration: /etc/nuxeo/nuxeo.conf
Include template: /var/lib/nuxeo/server/templates/common-base
Include template: /var/lib/nuxeo/server/templates/common
Include template: /var/lib/nuxeo/server/templates/postgresql
Unable to fetch remote packages list
Unable to fetch remote packages list
Unable to fetch remote packages list
org.nuxeo.connect.update.PackageException: Package not found: nuxeo-dm

Some commands failed:

Searching over the web, I tried some commands. These two may give some informations :

The first one :

apt-cache policy nuxeo nuxeo-dm nuxeo-dam
nuxeo:
  Installé : 6.0-01
  Candidat : 6.0-01
 Table de version :
 *** 6.0-01 0
        500 http://apt.nuxeo.org/ trusty/releases amd64 Packages
        100 /var/lib/dpkg/status
nuxeo-dm:
  Installé : (aucun)
  Candidat : 5.4.2-01
 Table de version :
     5.4.2-01 0
        500 http://apt.nuxeo.org/ trusty/releases amd64 Packages
nuxeo-dam:
  Installé : (aucun)
  Candidat : 1.4-01
 Table de version :
     1.4-01 0
        500 http://apt.nuxeo.org/ trusty/releases amd64 Packages

The second one :

sudo apt-get install nuxeo-dm
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 nuxeo-dm : Dépend: sun-java6-jdk mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Thank you very much for your help.

Yann

0 votes



You shouldn't use the nuxeo-dm and nuxeo-dam debian packages, they're old variants of the distribution. I've removed them from the repository to avoid confusion.

Try to also remove /etc/nuxeo/pkglist.cache when you delete the packages directories.
Also, check your database settings to see why Nuxeo isn't connecting to it.

05/06/2015