How To hide the section in document viewer

Hi I want to hide the document actions tab in the document view. i have tried hiding using the comments but it will be hidden in all over the documents.

Please see the screenshot below screenshot. https://prnt.sc/il8puu type an image title

in the above link i want to hide section1 not section2.

when i tried to hide it will hide both the documents.

Please help me solve the issue.

0 votes

1 answers

419 views

ANSWER



Activate debug mode, retrieve the id of the action you want to hide, configure the XML extension of the action accordingly (disable the action or define a filter).

https://doc.nuxeo.com/nxdoc/filters-and-access-controls/#managing-filters-to-control-an-action-visibility

0 votes



pibou Bouvret where the id located.
03/01/2018

pibou Bouvret Where to define an extension point
03/01/2018

https://doc.nuxeo.com/nxdoc/how-to-contribute-to-an-extension/

an XML file under templates/custom/config is fine

I don't have debug configured on my server but if I remember well, you have to enable debug in the upper menuand then shift click on the part of the UI. Otherwise you can look for the action contribution in platform explorer : http://explorer.nuxeo.com/nuxeo/site/distribution/

03/01/2018

pibou Bouvret Thanks for replay. i have included in the path but i got the errors like this. please see the screenshot http://prntscr.com/ilcjvs
03/01/2018

I don t know what action you have to override, but it should lead to something like

<component name="org.nuxeo.ecm.platform.threed.layouts.override">
    <require>org.nuxeo.ecm.platform.threed.layouts</require>
    <extension target="org.nuxeo.ecm.platform.actions.ActionService" point="actions">
        <action id="summary_threed_viewer" order="50" type="widget">
            <category>SUMMARY_PANEL_LEFT</category>
            <properties>
                <property name="widgetName">summary_threed_viewer</property>
            </properties>
            <filter-id>hasThreeDFacet</filter-id>
        </action>
    </extension>
</component>

component = custom name

require = the component you want override

03/01/2018

you can then disable the action or use a filter
03/01/2018

pibou Bouvret i have used like this please see the below screenshot. http://prntscr.com/ildwdo . it is not worked and i removed but still getting the same error only
03/01/2018

component should have a custom name

Platform explorer generates XML files such as

<component name="org.nuxeo.XXX.override">

There is no required component to override

Cannot find any nuxeo-document-viewer action in LTS2017, that 's the name name of a dom module in Polymer

03/01/2018

pibou Bouvret i changed like this please see the screenshot. http://prntscr.com/ilec0p is this will work
03/01/2018

set org.nuxeo.dev=true in nuxeo.conf and then https://www.awesomescreenshot.com/showImage?img_id=3208377

asking 3 times the same question won t help

03/02/2018

pibou Bouvret thanks i have configured the logs for that service please see the screenshot i havent find anything in logs http://prntscr.com/ilqr93
03/02/2018

pibou Bouvret i have changed it to dev mode where can i get the id
03/02/2018

pibou Bouvret your linked screenshot is not displaying any image
03/02/2018

pibou Bouvret I AM not using nuxeo studio is it possible with out using the nuxeo studio
03/02/2018

Did not mentionned Nuxeo Studio
03/02/2018

pibou Bouvret but i wont find anything like mentioned in your screenshot
03/02/2018

You re using the Web UI. Don t know if dev mode is working here. You ll have to dig in Platform Explorer in order to find your action
03/02/2018

pibou Bouvret i have applied your configurations extension provided i applied like this but it is not giving any error but it is not hiding anything.

Please see the screenshot. http://prntscr.com/ilveik

03/02/2018

<component name="org.nuxeo.ecm.liveconnect.action.override">
<require>org.nuxeo.ecm.liveconnect.action</require>
<!--...-->
<extension target="org.nuxeo.ecm.platform.actions.ActionService" point="actions">
<action id="blobAppLinks" type="template">
<category>BLOB_ACTIONS</category>
<properties>
<property name="template">/incl/action/app_links_action_template.xhtml</property>
</properties>
</action>
</component>
03/02/2018

That's the code generated by platorm explorer for the blobAppLinks Action Id That s part of org.nuxeo.ecm.liveconnect.jsf Bundle …
03/02/2018

pibou Bouvret i have tried your configuration provided too but it too doesn't hide the section required after the configuration it wont hide the actions required. Please see the screenshot https://prnt.sc/ilvzy0
03/03/2018

pibou Bouvret i used the xml like this. Please see the screenshot http://prntscr.com/ilw5b4
03/03/2018