Problem with Nuxeo Drive registration when Kerberos module is installed

The Kerberos addon makes Nuxeo Drive account creation fail.

In previous client (2.0.0.0522), registering the client worked with or without kerberos module in the server. So installing that version and then upgrading to 2.0.818 is a possible workaround.

The problem is that creating an account in a Nuxeo server without Kerberos generates this requests http://nuxeoserver.com:8080/nuxeo/drive_login.jsp?applicationName=Nuxeo+Drive&forceAnonymousLogin=true&deviceDescription=Windows+Desktop&deviceId=XXXX&permission=ReadWrite

Server responds with a 302 and a new requests is made: http://nuxeoserver.com:8080/nuxeo/login.jsp?deviceDescription=Windows+Desktop&forceAnonymousLogin=true&permission=ReadWrite&requestedUrl=drive_login.jsp%3FapplicationName%3DNuxeo%2BDrive%26forceAnonymousLogin%3Dtrue%26deviceDescription%3DWindows%2BDesktop%26deviceId%XXXX%26permission%3DReadWrite&deviceId=XXXXb&applicationName=Nuxeo+Drive

After setting our credentials in the form, that registration is complete and the syncronization starts.

However, when kerberos is enabled, the response to the first request is a 401 and the second request is just http://nuxeoserver.com:8080/nuxeo/login.jsp

And after write our username and password we are redirected to Nuxeo main page instead of registering our Nuxeo Drive client.

0 votes

1 answers

1164 views

ANSWER



I've just found it is solved in 7.3: https://jira.nuxeo.com/browse/NXP-16791

Is it planned to be patched for 6.0?

1 votes



Thanks. Just backported the fix, it will be available in 6.0-HF20.
09/07/2015

Perfect then.

Thank you.

09/07/2015

I have to do more testing but after applying the patch it appears that Nuxeo Drive still does not login properly.

The kerberos module still redirects the initial request to http://nuxeoserver.com:8080/nuxeo/login.jsp

09/28/2015