Nuxeo connect errors

Hi i have installed NUXEO 5.8 LTS and iam trying to use Nuxeo connect to register my instance and use the marketplace addon, but i just cannot seem to make it work.

I created a nuxeo connect account and have two applications listed there, the CLID and the technical Id are generated. When i provide the same from the Admin center in the nuxeo connect section it keeps saying instance not registered.

Here are the list of issues i saw when starting up nuxeo and while trying to connect to Nuxeo.

  1. PKIX error certificate not found in the path requested.

i created a self signed csr and keystore and made nuxeo point to it and tried again

  1. Preemptive authentication requested but no default proxy credentials available

i have provided anonymous proxy in the admin center so it should not be requiring any form of authentication, i don't understand why i am getting this.

By the way weird thing is I once saw that my instance was registered in the connect section and i was able to access Marketplace once , but after the next restart it never connected again.

What are the possible things am missing in configuring the nuxeo connect.Please help, thanks. We are trying to evaluate Nuxeo for our org.

0 votes

1 answers

1816 views

ANSWER



Hi,

When running “./bin/nuxeoctl showconf“, do you see a line with “Instance CLID: XXXX–XXXX” (DO NOT PASTE ITS CONTENT HERE)?
If so, what is the output of “./bin/nuxeoctl mp-update -dc org.nuxeo.connect“?

0 votes



Hi ,

Yes there is a CLID in it and here is the error when i try to connect using the commands you have provided.This CLID is a registered instance on the nuxeo connect website that i can see.

sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target.

  1. Does my java key/truststore need to have the nuxeo server certificate or do i need import my own self signed certificate in my key/trustore..i am not very clear on this. a. If it's a self signed certificate that is required. I have created a private key and a CSR and is stored in my store.jks and i have made nuxeo to point to the same.

Thank you for your help.

02/24/2014

Here are some debug logs enabled in Nuxeo and i see them when i log into NUXEO

"CONNECT connect.nuxeo.com:443 HTTP/1.1"

"User-Agent: Jakarta Commons-HttpClient/3.1[r][n]"

"Host: connect.nuxeo.com[r][n]"

"Proxy-Connection: Keep-Alive[r][n]"

"[r][n]" "HTTP/1.1 200 Connection established[r][n]"

"HTTP/1.1 200 Connection established[r][n]"

"[r][n]" [org.apache.commons.httpclient.HttpMethodBase] Response content length is not known

"GET /nuxeo/site/connect-gateway/registred/status HTTP/1.1[r][n]"

"X-NUXEO-CONNECT-TS: 1393455108091[r][n]"

"X-NUXEO-CONNECT-CLIENT-VERSION: protocol: 1.4 / build:1.4.13[r][n]"

"X-NUXEO-CONNECT-DIGEST-METHOD: MD5[r][n]"

"X-NUXEO-CONNECT-CLID: 6a9c92a9-ac69-4a41-b7ec-445d82b89314[r][n]"

"X-NUXEO-CONNECT-CTID: Windows 7-KoPbpFYG0wqz4FmLGogUvA==-xtFr90ohs2EDD7rDKa7fvQ==[r][n]"

"X-NUXEO-CONNECT-DIGEST: 56gz1q/DwQHQ5plh2JYNfw==[r][n]"

"User-Agent: Jakarta Commons-HttpClient/3.1[r][n]"

"Host: connect.nuxeo.com[r][n]"

[org.nuxeo.connect.client.status.ConnectStatusHolder] Error while calling connect server aused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

How do i go about fixing this to enable nuxeo connect.?

02/27/2014

Here is what i did to get the server certificate.

  1. went to https://conect.nuxeo.com which redirects to sso.nuxeo.com. Exported the root certificate which says USERTrust certificate into a DER supported x509 format .cer file
  2. Used Keytool to import to my default cacerts file in java_home.
  3. Pointed nuxeo.conf to this cacerts file.

The above steps still did not work and have the same error, nothing has changed.

Is the server address from which i got the certificate from ,is that correct, is there anything else missing. Does it require it to have my self signed certificate as well

03/05/2014

What did you do for the third point?

I'd say it's the right certificate. You don't need a custom certificate.

03/06/2014

-Djavax.net.ssl.keyStorePassword=changeit -Djavax.net.ssl.keyStore=C:/Keystore/jre6cacerts/cacerts -Djavax.net.ssl.trustStore=C:/Keystore/jre6cacerts/cacerts -Djavax.net.ssl.keyStoreType=jks

These are the properties i configured in my nuxeo.conf to point to the certificates.

03/06/2014

I tried adding the certificates to all the jre cacerts file in my system and tried it as well.
03/07/2014

did you check that Nuxeo process is started with these JVM options?
03/11/2014

yes the params are reflected in the server console each time i change them
03/11/2014

any update on this? I have seen the same issue now. I did all the advise above, like adding these java opts , add certificate. Still same error happened.
09/14/2015