Studio Issues: Platform cannot update, master-SNAPSHOT not built, cannot release a version

Hello,

Studio today has been acting strange. Today I made an edit to a Table Layout, hit the 'Save' button, then went to my local instance of Nuxeo Platform. This is linked to my studio project, and has been working for months. However when I go to the Admin tab on platform, the Update Center section, and click the Update button, it doesn't download the latest changes from studio. I get:

ERROR: Problem while downloading package: null

So then I wanted to check the master snapshot it should be providing by checking it's linked (this is not a valid link, using 'project-name-here' for privacy sake of project. This is to give the idea of what type of link I used). https://connect.nuxeo.com/nuxeo/site/studio/maven/nuxeo-studio/project-name-here/master-SNAPSHOT/

This gives a listing of files related to the master-SNAPSHOT including the jar file (what should have been downloaded during the Update process). However when clicking on the link to the jar file, I was expecting to download the file, but instead I got:

HTTP Status 500 - com.nuxeo.studio.client.model.StudioException: Failed to build feature with type 'branding' and id 'project-name-here'

So what it seems like is it is not performing a successful build of the jar file. However if that was the case, then there would have been red exclamation marks in studio, but there wasn't any.

We tried to see if we could then make a new release, to see if a new jar would appear then. However, when attempting to make a new release, it doesn't appear under 'Release and Tags' section of studio. We cannot do anymore releases currently.

We also tried doing a commit revert back to the last time we confirmed studio was working (where we made a change, and were able to successfully download the master-SNAPSHOT jar file). We were able to do the revert on studio, but we still got the same error where it doesn't create a master-SNAPSHOT.

The last time we confirmed studio was working was on April 5th 2018, so we don't know if there has been any changes on nuxeo/studios front that would have possibly affected the way studio works. Are there any ideas on how to fix this, or has this happened for anyone else?

0 votes

1 answers

68 views

ANSWER



Please check the warning that displayed in top after login Studio. Follow the instruction

  • You can go to Application Definition and save it once
0 votes